I am observing a very strange behavior. I have published a network service on version 10.61. When I click on


I get following travel modes which are not defined in my network data set.

  • Walking Time
  • Rural Driving Distance
  • Driving Time
  • Driving Distance
  • Walking Distance
  • Rural Driving Time
  • Trucking Time

When I try to get travel mode on the same network data using


I get following travel modes which I defined in my network data set.

  • Avoid Planned Roads

I have tried publishing same network dataset twice on my server but I am observing the same behavior.

What I am missing here ?

1 Answer 1


The problem is resolved now and I would like to share the solution so i am answering my own question.

I tried publishing multiple network datasets and the issue was same. This was causing an issue in configuring the directions widget in Web App Builder as well.

However this is resolved now. I am using ArcGIS Portal and it turns out this was configured in portal settings. I have to remove the default settings of portal (Under Organization -> Utility Services -> Directions and Routing -> Routing Utilities URL)

It was overriding the travel modes which I published in my network service. Now when I removed this from our staging portal I am getting the correct travel modes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.