0

I have installed all of the necessary programs for this process (Anaconda, Step SNAP, Sen2cor, etc). I have installed the plugin for sen2cor in SNAP.

When I run the Level1-c product through Sen2cor, I get a complete file made and placed next to my L1C folder.

In SNAP, I am unable to either import the L2A product or to open it as a product. For both functions I get the following error message: No valid tiles associated to product [MTD_MSIL2A.xml]

enter image description here

However, I am able to open the L2A product in ArcMap, which is where I want to do most of my analysis anyway. But, is this a reliable output?

Also, there seems to be quite a difference between the normal RBG true color image I generate in SNAP versus the one I generate in Arc. Is this due to some inherent difference of processing capability or because SNAP automatically did a lot of processing?

The SNAP image is much brighter and clearer than the one in ArcMap.

SNAP True Color RGB: enter image description here

ArcMap True Color Composite: enter image description here

  • Was there any output message from Sen2Cor? I haven't used Sen2Cor from SNAP but this sounds like there was some error in the final steps which did not create the product manifest file (MTD_MSIL2A.xml). For the visual difference between SNAP and ArcMap, this is likely just a visualisation issue, i.e. how the program scales the actual pixel values to be shown on screen. There should not be any differences in the image. You can check this by exploring individual pixel values in both SNAP and ArcMap and see if they match. – danscr Jun 14 at 10:33
  • @danscr I do not receive any output message after processing, it just runs and then returns to a normal screen. However when I ran it, it did create the MTD_MSIL2A.xml, but it will not open in SNAP – A. McCrea Jul 14 at 22:40
  • I can't quite judge how sen2cor behaves inside SNAP. A workaround would be to use the standalone version of Sen2Cor from the command line, this should give you some information on what might have gone wrong. Sorry I can't help with the plugin – danscr Jul 31 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.