1

I am trying to use the mmqgis animate lines tool to animate some lines. But for some reason the dialogue box has the "print layout" section greyed out.

animate lines tool screenshot

The line layer is called 'POC 3 to POC 4 shape', the data looks like this

data screenshot

I change the directory to somewhere convenient for me and because print layout is greyed out this is the result.

layout not found screenshot

I have tried uninstalling and reinstalling mmqgis, I have tried manually installing the plugin by dropping it into the plugins directory and the same problem persisted.

I even tried an older version (last 2016 variant) and of course, QGIS refused to run it as it is incompatible with my version of QGIS (3.2.1)

Anyone else having the same issue?

Ultimately I just want to animate a bunch of lines

2
  • Do you have a print layout set up in this QGIS project?
    – csk
    Jun 6, 2019 at 18:06
  • @csk this was the issue all along. thank you. after creating a print layout, everything worked. Jun 28, 2019 at 5:45

1 Answer 1

1

The problem is because I didnt have a print layout created first.

to do this you simply going to project > new print layout, give it a name, drop the map in and save. then run the animate lines tool from mmqgis.

Thank you to @csk and Reddit user u/clint20040

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.