3

I've written a plugin for QGIS (GeoDataFarm) and I've been using QT creator for all ui files of the plugin, which have worked fine for me. However, I just got an email from someone that tested my plugin on high resolution screen 3200x1800 pixels and apparently it does not work.

This is how the screen look on my computer: Image on Normal screen

This is how it looks on a high resolution screen: Image on high res screen

Any suggestions on how to fix this? Is there any good way of "locking the layout" in QT creator?

Is there any way of testing how it looks on different resolutions, my maximum resolution is 1920x1080?

  • Are you using Layouts (vertical, horizontal, grid, form) ? – J. Monticolo May 31 at 7:37
  • No I've just dragged stuff into the different tabs, will layout (s) solve this issue? – axel_ande May 31 at 8:05
  • Yes I think, I suggest you the grid layout. Layouts organize the space in the widget tab. Note that you can define for each Tab widget (and other containers widgets) the layout. – J. Monticolo May 31 at 8:15
  • I've played around with a grid layout a little bit, but I think (by changing the font size in Windows 10) that it doesn't help. Or the text in the labels and buttons "becomes too big" i.e. some characters (on buttons) and some lines (in long labels) "disapears". So layout keeps everything on the correct space but I also want it to "auto shrink" the text size to fit. – axel_ande May 31 at 8:35
  • You can set the wordwrap settings and force the minimum size of your objects. – J. Monticolo May 31 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.