0

I would like to get the output of the following command :

gdalinfo --formats > formats.txt

In Linux, it works

In Windows, it works but the output is not completed.

Do you know how to get the complete output in Windows ?

EDIT : I know it's not complete because it finished in the middle of the line End of my file :

GSC -raster- (rov): GSC Geogrid
FAST -raster- (rov): EOSAT FAST Format
BT -raster- (rw+v): VTP .bt (Binary Terrain) 1.3 Format
LA

I try different OS, windows 2016, 2019, 10 and differents versions of GDAL, the last one i try is 3.0.0.

EDIT 2 : I run some test and found out the problem but don't know how to handle it. So I took the gdal from here : Gdal with mapserver

From here bin\gdal\apps I copy gdalinfo.exe and put in in bin.

I run gdalinfo --formats > formats.txt and it works

But after that I add a plugin ECW From Here

I extract the msi, I copy paste the gdalplugins and libecwj2.dll to the previous bin folder

And now the commands is not completed. I don't know why.

  • 1
    Works for me with GDAL 3.1.0dev and GDAL 2.4.0. – user30184 Jun 5 at 9:58
  • Not completed how? Does the output end in the middle of a line? Or are there whole lines missing? How do you know? Does it look okay when not piped to a file? – Spacedman Jun 5 at 11:01
  • I Edit my questions, the output end in the middle of a line and I try different OS and version of GDAL. – Sébastien Legrand Jun 5 at 11:56
  • Works for me GDAL 2.4.0, windows 7. – HeikkiVesanto Jun 5 at 14:59
  • The problem is that I add a plugin (ECW), before adding the plugin the command works as expected after I add it, it doesn't – Sébastien Legrand Jun 6 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.