3

I have a taxlot that is giving me troubles in a Union. When I try to run the union I get the tried and true ''Geometry is not M-Aware'' message. (there are no Polygon-M features). Based on readings on this site and the ESRI forums, I'm now trying to explode my taxlots prior to the union. However I seem to have come across a mystical indestructible shape. I've tried check and repair geometry with no results. I've tried the Multipart-to-Singlepart tool and receive this message:

Cannot process feature with OID ...
Failed to execute

So I tried the explode function in the Advanced Editing Toolbar and go this lovely message:

explode fail

I calculated (!SHAPE!.partCount) the number of parts into a field and came up with 22.

Here is what the shape looks like:enter image description here

Help?

  • Try repairing the geometry first. – nagytech Aug 30 '12 at 5:45
  • Already tried that. *edited question to include that. – valveLondon Aug 30 '12 at 5:48
  • 1
    If this is a shape file, import it into a geodatabase. Doing that, on some occasions, is known to 'clean' some 'corrupt' geometries. If not, then I'm all out. – nagytech Aug 30 '12 at 5:54
  • No go...thanks for the ideas though! – valveLondon Aug 30 '12 at 6:04
  • What messages are you picking up in the geoprocessing results window? – Aaron Aug 30 '12 at 13:03
1

You mentioned using Explode from the Advanced Editing Toolbar - have you tried the Multipart to Singlepart tool in ArcToolbox?

  • Yes, I tried that. – valveLondon Aug 30 '12 at 6:38
  • Perhaps try using GDAL to convert to/from JSON or XML, as described here to see if that cleans up the error? – Stephen Lead Aug 30 '12 at 7:10
1

a workaround would be to convert feature to lines, and then back from line to polygon. The you create the centroid inside each new feature in order to recover the attribute (and maybe delete the slivers,which will not contain points.

0

I'm thinking along the same lines as @Stephen Lead.

In Workstation days, anything with corruption hard to clear was usually a candidate for UNGENERATE/GENERATE so it could be sorted in a text editor. The nearest thing to that in ArcGIS for Desktop appears to be Write Features to Text File and Create Features from Text File in the now deprecated Sample Tools. It would be nice if ArcPy's AsShape to import GeoJSON had something that would export to it as well because that would be similarly easy to manipulate.

Here's an ArcGIS Idea that you may want to add your vote to.

0

I had this issue in Arcmap 10.1. However, I would not see a dialog screen saying the operation couldn't be performed, but the multiple parts would not seperate as multiple polygons.

I had a polygon with donut holes within it that I wanted to remove. I used the edit vertices tool and opened the sketch properties window to see the multiple parts, and deleted the parts I didn't want from there.

0

I had this same issue and what fixed it was running the "Repair Geometry" tool on my feature class/shapefile and that allowed me to explode my data.

protected by Midavalo Dec 31 '17 at 16:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.