1

I currently have a collection of assets of different data types (points, lines, and polygons). I'd like to find the intersection between each individual asset and the polygon mask. However, for example, when I try to use the Intersect (analysis) tool as seen below, and I input my mask followed by my asset layers, I'm getting error 000117: empty output generated.

I'm assuming I'm getting this error because there's no overlap between any of the assets (ex, no intersection between asset_point and asset_poly).

Is there any way to do this in a batch instead of manually doing an intersection for each layer?

I'm using ArcGIS Desktop 10.5.

enter image description here

2

It is likely to be constrained by your licence type:

With ArcGIS Desktop Basic and Desktop Standard licenses, the number of input feature classes or layers is limited to two.

If you right click on the intersect tool in the toolbox there is a batch option. Which will open a window where you can input your multiple assets against the mask: enter image description here

Hope that helps.

  • This seems like the answer, however, after adding the inputs and the output name, the tool runs immediately, and says it runs successfully. However, it only completes the first row, and the output isn't appearing in the database. Thoughts? @MAJ742 – Jared Jun 5 at 14:40
  • If you double click the number one that should bring up the original tool interface - double check all the parameters are complete there. Also, as per your original question - have you done a visual check to make sure there are definitely features overlapping the mask? – MAJ742 Jun 5 at 14:43
  • Yes - I ran it once manually with each data type to confirm there are intersections, and those came out just fine. I just tried it again and double-checked to make sure all parameters were the same. I even tried a batch with JUST one row, the mask and the polygon asset, which gave me the same issue. – Jared Jun 5 at 14:47
  • hmm not sure I'm afraid. A quick check of the batch method using a polygon and point feature in the input features on my system appears to have worked without a problem so not sure what else to suggest without seeing more of the data or file locations etc. – MAJ742 Jun 5 at 14:56
  • 1
    Final Update: For some reason, it wouldn't write the data to my GeoDatabase, but worked fine when saving the outputs to a folder. Not 100% ideal, but works for now. Thanks. – Jared Jun 5 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.