2

I do not seem able to create a square buffer around a point feature with v.buffer in GRASS GIS v.7.4.4.

The documentation states that "Using -s with a point vector map as input data, square buffers are created instead of round buffers." However, below is the command I ran, and the resulting buffer. Am I missing something obvious?

v.buffer -s input=vectmap type=point output=test_buffer distance=1000

enter image description here

2

Worked for me. What operating system and which version of GRASS are you using?

micha@TP480$ v.buffer -s ims_stations_s type=point out=ims_buffers dist=1000

square buffers

2

Just to confirm again, it worked for me as well. Might worth double checking which version of GRASS you are using. I tried with GRASS 7.6.1 in Linux mint and Windows 10 with WGS 84 / UTM projection.

v.buffer -s --overwrite input=Points@PERMANENT output=square_buffer distance=100

Square buffer

0

The 'problem' was encountered with GRASS 7.4.4 in Windows 10, but the option of making square buffers around points by use of the -s flag was not included until GRASS 7.6, as per the release notes: https://trac.osgeo.org/grass/wiki/Grass7/NewFeatures76

The manual cited in the original question thus pertained to a newer version of GRASS than the one I was using, and I was indeed missing something obvious. Everything works fine with GRASS 7.6 in Windows 10.

Thanks for checking and pointing me in the right direction.

  • Glad it works also for you - please accept the correct answer. – markusN Jun 7 at 5:26
  • Yes. I still have to wait three hours to be able to accept my own answer as correct. – humperderp Jun 7 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.