1

I'm trying to set up GeoServer to serve map data to Kibana. So far I managed to get data from the US national weather service into Kibana so I know the concept is working.

https://www.elastic.co/blog/custom-basemaps-for-region-and-coordinate-maps-in-kibana

Next I installed GeoServer and created a layer with a shapefile as source as per the documentation. The layer shows up fine in the preview but I can't get Kibana to show it.

Now the Kibana documentation is rather lacking when it comes to WMS documentation but I found this in the link above:

Geoserver / MapServer / ArcGIS Server

A more advanced scenario might have you running your own instance of Geoserver, MapServer, or ArcGIS Server. These software packages may or may not come with geospatial data needed to create basemaps. You might check out our blog post on using a custom Geoserver basemap with Elasticsearch.

To be compatible with Kibana, basemap tiles created with these software packages must be cached as raster tiles in the Web Mercator (EPSG: 3857) coordinate system. All of these software packages can publish WMTS services. You can review the ArcGIS Online example above to determine the tilemap.url parameter from WMTSCapabilities documents created by these software packages.

Under layer settings I found Coordinate Reference Systems clicked the find button and scrolled untilI foundEPSG:3857`. That alone did not work though.

Upon further investigation it appears shapefiles are also in vector format. (For some reason in the GUI you have to click to store, and then hit the return button to see the text value because the icon has no text overlay.)

Is there any way I can serve my layer as a raster?

My original data is in .kml format. Also if anyone has ever managed to get Kibana show GeoServer data I would love to hear what other steps might be necessary.

  • 1
    You need to set tile caching on your layer to get a geoserver wmts, which is what kibana requires (not WMS). A shapefile input is not a problem, geoserver creates the image as part of the service – nmtoken Jun 6 at 7:52
  • Thank you. But under edit layer Tile Caching create a cached layer for this layer and enable tile caching for this layer are already enable. Is there something else I need to set? I also noticed the entries under Gridset are different from what Kibana demands. – sjaak Jun 6 at 8:00
  • Can you add the details of what kibana wants to your question – nmtoken Jun 6 at 8:02
  • The Kibana requirements are in bold in the quote in the opening post. Kibana requires raster tiles with EPSG: 3857 coordinates. – sjaak Jun 6 at 8:10
  • What about the entries under gridset you mentioned – nmtoken Jun 6 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.