I have a problem with the Field Calculator in ArcGIS 10.

I selected specific points of a Shapefile I want to calculate, but FC is always calculating all fields. Unfortunately there is no checkbox in ArcGIS 10 anymore to tell FC to only calculate selected fields.

I discovered that it seems to be a problem with the Attribute Table since values can only be changed manually while being in the "Show selected records" mode. Otherwise my edits won't be even recognized (even actual typed in ones).

I tried both activated Editor and not activated Editor for FC. Just a few minutes ago everything worked out fine, now all Shapefiles can't be calculated according to the selection anymore. :/

Anyone an idea what went wrong?

I'm not aware of having changed any settings.

Restart of ArcMap also doesn't do it.

closed as off-topic by PolyGeo Aug 20 '15 at 8:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I found the opposite to be the case. I'd inadvertantly left one record selected and couldn't figure out why my field calc operation wasn't running on all fields. gis.stackexchange.com/questions/29235/… – Roy Aug 30 '12 at 12:09
  • It seems not to be a selection problem. No matter how many fields are selected (or none) all fields are always being calculated (or better say: filled). Could it be a bug? – basto Aug 30 '12 at 12:35
  • 2
    Several times you've mentioned selected fields when I think you must be meaning selected features because the Field Calculator only works on one field at a time. – PolyGeo Aug 30 '12 at 13:04
  • 1
    ah yes, I'm sorry for this. Of course I mean selected features. – basto Aug 30 '12 at 13:20
  • What service pack are you using? – Get Spatial Aug 30 '12 at 15:10

I found that field calculator does funny things when feature class is outside spatial (!) extent.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.


We have a similar problem at least with ArcMap 10 SP5.

If we join two tables Field Calculator is always calculating the values for all features - even if we select only some features.

If we have no tables joined Field Calculator behaves as expected. Only the selected features are updated with new values.

I think this is a serious bug.

  • Thank you for this comment! This sounds similar to my problem. How about if you create a new Shape File from your joined tables (if you have spatial reference) and calculate then? I geocoded an Excel table which resulted in a Point Shape File of course, where the Field Calculator problem (still) occurred. Only restart of ArcMap and Import of the Shape Files into a new MXD file does the trick. – basto Sep 5 '12 at 11:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.