11

I have downloaded several SRTM DEM raster tiles from https://dwtkns.com/srtm30m/, and created hillshade versions from the tiles. However, upon closer inspection, the hillshade tiles now have border lines that I do not know how to hide or remove (like in the image below, which shows the border lines of the 4 tiles):

SRTM tiles hillshade border lines

I tried checking the Styles options but cannot find a way to hide the lines/borders. When trying to render the tiles as singleband pseudocolor, no lines are shown, so I am suspecting the lines are only generated when doing a hillshade render:

How can I hide/remove these hillshade tile border lines?

SRTM tiles singleband pseudocolor

  • Side note: since these tiles belong to the north hemisphere, you may wish to apply hillshading coming from a South direction, since that's the angle with which the Sun illuminates the northern hemisphere. – jjmontes Jun 10 at 14:05
13

SRTM tiles (3601 px * 3601 px in this case) have 1-pixel overlaps in between. When you apply transparency (or reduced opacity) to your hillshade layer, such overlapping pixels stand out. You may have observed this also on the original images, if you apply transparency (see below).

enter image description here ..... original SRTM, Pseudo-color + 60% opacity

Anyway, you can avoid this by merging these tiles. One way would be Build Virtual Raster (either from menu > Raster > Miscellaneous, or from the Processing Toolbox).

enter image description here

Do not tick on Place each input file into a separate band option.

After setting hillshade on the Virtual Raster Layer, you will not see the boundaries anymore.

enter image description here

3

As described by @Kazuhito, the tiles should be combined into a virtual raster. Their method is performed within QGIS. If you have a large number of tiles you may prefer to do this from the commandline. To do so open a shell in the directory containing the SRTM tiles and run gdalbuildvrt combined.vrt *.hgt The resulting virtual raster (combined.vrt) can then be loaded into QGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.