I've designed a model which compares some shapefiles to other shapefiles (I want to see if the files I get are the same as the files of my template). When I try to publish the toolbox (where the model is found) on the server I get this message "Configuration can not be started. Server Object instance creation failed on machine....Geoprocessing service initialization failed. Invalid parameter: Tool..."

SOC has full access to the folder where my toolbox is so this can't be it. Is it because I'm working with shapefiles? Or why would the parameters be invalid?

I am using ArcGIS Server 10.0; ArcDesktop Editor 10.0.

enter image description here

1 Answer 1


I think an error like yours, seen when you try to Start a Geoprocessing Service either manually or as part of Add New Service (i.e. when it is first created), is likely to be due to trying to start too many Geoprocessing Services for the resources the hardware hosting them has available.

If you Stop one or two others then you should be able to Start this one.

If you do have too many Geoprocessing Services running for your resources, and are publishing each task from a different map, then perhaps try adding multiple tool layers to just one map before you publish it as a Geoprocessing Service with multiple tasks available.


Just realized that you are publishing a toolbox rather than a map with tool layers so much of what I said above may not apply. However, if this toolbox does not publish then maybe a smaller one with less tools might? If that's the case it would still point at system resources being limiting.


It seems like the error message I looked up and "matched" to this question is not quite the same.

Configuration ****/****_****.GPServer can not be started.
Configuration ****/****_****.GPServerJobScheduler can not be started.
Server Object instance creation failed on machine ****.
  Error: 0x80080005 (Server execution failed)

I now think that attention should be paid to the "Invalid parameter" part of the Question's error message. I think you should double-check that the tool can be run from ArcGIS Desktop on the server where you are trying to run it as a GPservice. I would expect that would throw a similar error and enable you to focus on debugging the model and dialog rather than the service.

  • tried to publish a toolbox with a really small model. and still no.
    – Ligia
    Sep 3, 2012 at 8:55
  • Have you ever been able to publish a toolbox or a map to this server? If not, is it already overloaded with other resource hungry applications that could be turned off temporarily to see if that makes enough resources become available to publish your GP service?
    – PolyGeo
    Sep 3, 2012 at 23:01
  • I did publish other toolboxes on the server, and apparently I still can publish small models, but not precisely this one. I added a photo with the error. I have only one map service started, all the other ones are stopped.
    – Ligia
    Sep 4, 2012 at 6:50
  • 2
    +1 Invalid parameter sounds like something discussed in Input and Output Data Types. Sep 6, 2012 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.