2

I'm converting a reclassified raster (with a resolution of 25.18m) into a polygon. The reclassified raster has values of only 0s and 1s. However, the conversion results in a polygon with vertical lines of missing values. Would anyone happen to know why this is happening, and how to fix it?

A few things:

  1. I've tried using geographic and projected coordinated systems
  2. The original file is a land use raster
  3. Tried this on ArcGIS and QGIS.
  • Are the vertical lines in the raster? What format is the raster? I've seen this happen with .BIL files in previous versions, the fix is to translate from .bil (EHdr in GDAL) to GeoTIFF or Erdas img (HFA in GDAL) before running raster to polygon. – Michael Stimson Jun 11 at 6:29
  • Thanks for your suggestions. There no vertical lines in the raster; only the polygon has them. The raster is in GeoTIFF format. – PKP Jun 11 at 11:39
  • That is indeed odd, it could be a decompressor issue, can you try converting (QGIS Translate or ArcGIS Raster to Other format) to Erdas IMG format, this format doesn't support compression (other than RLE - Run Length Encoded) which would eliminate any decompression issues from this workflow. If this doesn't work can you include a screenshot with both the raster and polygons visible showing the vertical lines, zoomed in to see individual pixels. – Michael Stimson Jun 11 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.