When trying to create a new shapefile in QGIS on Ubuntu, I get a crash whenever I browse to a folder to save the file.

Has anyone else experienced this?

  • 3
    Please, provide us with QGIS and Ubuntu versions. Also, please start QGIS from console and post here any valuable output on crash from there. – SS_Rebelious Aug 30 '12 at 22:34
  • do you launch it as a superuser? – Aname Aug 31 '12 at 12:51
  • All: Ubuntu 12.04 QGIS 1.8 This happens in several functions where the 'minimal' file browse dialogue comes up...do you know the one I'm talking about? – DPSSpatial_BoycottingGISSE Sep 19 '12 at 22:34

All- seems this is a problem with other Ubuntu software as well.

Using Scribus, a similar problem was occuring.

Sure enough, their developers tracked it down to a problem with the QT library (see below).

Having this issue resolved, I immediately tried to open QGIS and create a new shapefile. The browse dialogue that "create new shapefile" uses - which for some reason is a different system dialogue box than usual - worked just fine!

My conclusion is the QT bug was affecting QGIS as it was Scribus!




This bug in scribus-1.4.1/ubuntu-12.04 is written up here .. https://bugs.launchpad.net/ubuntu/+source/scribus/+bug/973332 this may be resolved by uninstalling the qt-at-spi package through Synaptic Package Manager. or sudo apt-get remove qt-ap-spi This bug is reported as fixed in Qt 4.8.2 However in my ubuntu 12.04 I do not experience any such crashes and my qt-at-spi package accessibility plugin for qt reports latest available version 0.2.0+git20120411-0ubuntu1


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.