I changed from QGIS 1.7.3 to 1.8.0. Problem is that I can´t open QGIS Projects, QGIS crashes when there are layers involved loaded via access-database connection. I used eVis. What can I do?

  • Could you solve the problem with the non static MS-access connection? I have a similar problem with 1.7.1. I create a project with the connection to access. But when i save and close the project and start again there open a window calls "Defekte Layer behandeln" – user10738 Oct 5 '12 at 9:40
  • As I wrote above, it is only possible if you save the temporary file to another folder before closing Qgis, and copying it back to the original place. It may be solved in Qgis 2.0.0 ... – AndreJ Oct 5 '12 at 9:49

If its not a big project (not a lot of layers), consider starting from scratch?

| improve this answer | |
  • 1
    Good idea. Just open a new database connection, load a layer and save it under a different project name. Maybe that is already enough to reuse the old .qgis files. Otherwise you can compare the .qgis files in a text editor. Look for the <datasource> tags. – AndreJ Aug 31 '12 at 8:28
  • O.k. I tried but it still don´t work. I opened the project-file with edito and found following (see below) what is something wrong with it? <id>xy_Standorte20120831084035124</id> <datasource>file://C:/Users/oppia04/AppData/Local/Temp/qt_temp.ae5956?delimiter=%09&amp;delimiterType=regexp&amp;xField=GK3%20x%20coordinate&amp;yField=GK3%20y%20coordinate</datasource> – oppia04 Aug 31 '12 at 8:52
  • 1
    Nothing "wrong" so far. Is this the old (1.7.4) or the new (1.8.0) project file? You have to compare both. The problem is that the database is not written in here, instead a path to a temporary file. The new Qgis will open a different temporary file. You can exchange the path with a text editor if you know the new one. – AndreJ Aug 31 '12 at 9:46
  • my directory is "c:/Benutzer/oppia04" instead of "c:/users.." because of the german system but it becomes spooky.. There is no temp-file saved in this direction. When I create the connection I can see one the temp-file "hq_temp.hp1240" in the right direction (i.e. c:/benutzer...temp) after saving, closing and opening qgis it is gone. And the spooky thing is that after one trial it works, I created a connection saved it and there are two files "qt_temp.gq5544" and "qt_temp_hp5544" so the problem is with loading old files and the same when I create them with 1.8.0. Thank you for help!! – oppia04 Aug 31 '12 at 10:21
  • 1
    I have tested now on Windoes 7 with Qgis 1.7.4 and 1.8.0, but did not get managed to reopen a project even with the same version. Reading gis.stackexchange.com/questions/9462/… (last answer) I'm afraid evis only serves as a database importer, and the data is gone when closing the program. Only solution I see is to export the data to a shapefile or spatialite database immediately, and remove the access database layer before quitting. – AndreJ Aug 31 '12 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.