1

I was trying to generate a catchment area from a DEM and got the error message:

The following layers were not correctly generated.<ul><li>/var/folders/ft/rbsnpzy96r76t8rkj5fdtzc40000gn/T/processing_9c115a04040346468f5f515f34c18060/56eb9d666ec44bd5a5ffeb946d486006/FLOW.sdat</li><li>/var/folders/ft/rbsnpzy96r76t8rkj5fdtzc40000gn/T/processing_9c115a04040346468f5f515f34c18060/7d782906ca3b428899252f6f368f308f/FLOW.sdat</li></ul>You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

When I checked the Log Messages it indicated this:

             SAGA Version: 2.3.1

             ____________________________
             library path: /Applications/QGIS3.app/Contents/MacOS/lib/saga/
             library name: libta_hydrology
             library : Hydrology
             tool : Flow Accumulation (Top-Down)
             author : O.Conrad (c) 2001-2016, T.Grabs portions (c) 2010
             ____________________________

             Load grid: /var/folders/ft/rbsnpzy96r76t8rkj5fdtzc40000gn/T/processing_9c115a04040346468f5f515f34c18060/8340cdad8325410f9cb94c4a526ab5a8/hillshadeandyam3x3.sgrd...


             Flow Accumulation (Top-Down): could not initialize data objects

Any idea why it cannot initialize data objects, or how I could find out?

  • Also, I have tried saving as a file and this produces the same error. – Jesse Yishai Jun 14 at 15:54
  • Are you running this tool on a big DEM file? Could you add layer information, e.g. CRS, extent, dimensions? – Kazuhito Jun 14 at 16:38
  • It's 21.3 MB IMG file, 2250x2443, extent: 114896.4342999999935273,911289.7088999999687076 : 117236.8513999999995576,913630.1258999999845400 and CRS: EPSG:26986 - NAD83 / Massachusetts Mainland - Projected – Jesse Yishai Jun 16 at 23:05
  • It' fairly small. I see no reason you get the error... Just to confirm your IMG file is raster .img format, right? Not RGB composite image? (Sorry it is almost obvious, though). – Kazuhito Jun 16 at 23:15
  • Yes, it is a raster .img, it was downloaded directly from a state website in 9 pieces and I merged them together into 1. It loads fine into the map view. – Jesse Yishai Jun 18 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.