1

I am doing property research on a county in Texas. I have all the parcel data and am trying to dissolve by Owner Name so that I can use the info tool to quickly see all the properties a given person owns in the county. I have dissolved successfully in two other counties already and have employed the same process for this county. But for some reason when I hit "Run" in the dissolve tool, I keep getting the same error message. "-2147483645 See log for more details" See a picture of the error box below.

enter image description here

Unless I don't know where to look, I am not seeing any information on what the issue is. I have googled the error message with 0 results.

  • Have you checked, whether the geometry is faulty or not? Have you tried dissolving using another field? – Erik Jun 18 at 14:46
  • When I run the "check validity" tool I get the exact same error message. I have also tried to dissolve by owner address and get the same error message. I even tried to change the layer CRS and still got the same error message. – Hanover Jun 18 at 14:56
  • 1
    My geometry type is "Polygon (WKB type: "PolygonZ")". Should I change that? If so, what should I change it to and how do I change it? – Hanover Jun 18 at 15:54
  • 1
    It's not supposed to be an issue but you could try to drop it with "Convert geometry type" algo to polygon and try again – MaxPlank Jun 18 at 15:55
  • 1
    Solved! MaxPlank, you were right. The PolygonZ kept the dissolve from working I followed the description here gis.stackexchange.com/questions/209250/… and just changed "points" to "polygon" and then saved as a new shape file. When I tried the dissolve function it now works. – Hanover Jun 18 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.