0

I'm making some good ol' maps at work (Using 10.x) and I'm having difficulty getting my legend to fit with the amount of descriptive text I have and the amount of space available to me (as well as to make it look... you know... decent. Which can be difficult a lot of the times with how clunky layout view in ArcMap is).

Is there even a way to theoretically get ArcMap to un-gray-out the checkbox that has "Preserve Aspect Ratio" checked? Nothing I have tried has worked and my google - fu ended with someone who had a similar question and a response that was basically, "Sorry dude, ArcMap just be like that some times."

Ideally I would rather not convert the legend to graphics since you can't make changes easily to the legend after the fact, so is there a better way to do this without converting to graphics?

Here's a picture if it helps refresh your brain on where this is in the legend properties: enter image description here

2

Though not a true answer in the frame of the original question that I had, I was able to alter the text of my legend by turning on Text Wrapping (under the layout tab) and playing around with the label width. I did discover also that in order to un-gray-out the preserve aspect ratio radio button, the Fixed Frame radio button must be checked to allow you to change the bounding box of the legend freely. However, this still does not make your legend fit completely within the bounding box, it only changes the size of the bounding box for some reason. More playing around with this option will be needed in order to truly assess whether or not you can use that to squish everything inside of the legend the way you want it to without screwing other things up.

0

There are some things that you can do to modify the size, without actually modifying the size. Seeing as you want to retain the elasticity of your legend try these things (Right click legend>properties):

  1. In the layout tab, select "Wrap Labels". This may truncate your label text beyond what you're comfortable with. Play around with these values.

  2. In the items tab, select a layer (just highlight it) in which you'd like to start a new column with. Check the box "Place item in a new column". Break your legend items up into new columns. In my opinion, this give you the most control over the shape of your legend.

  • Sorry, should have been more specific. I have already checked things like Wrap Text and put things into different columns already. It did help make the legend wider (which was my goal) but it still isn't exactly as wide as I'd like it to be. – Noah_P Jun 19 at 19:07
  • You could also try adding "ghost" data, delete the name and set the symbology to hollow with no outline. Add it to your legend, and set it to a new column. Haven't ever tried it, but in a pinch I don't see why it wouldn't work. – mgallotta Jun 19 at 19:22
  • Also try change the legend frame's x and y gaps and/or create a graphic background box instead of using a legend frame, then group the box and the legend. – danak Jun 20 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.