6

I created a QGIS 3.6 project on Windows Server 2016 x64 with two PostGIS layers:

  • Layer A: Points
  • Layer B: Datatable (No geometries)

and configured QGIS Server options on the project like this:

enter image description here

Now I open on another PC a QGIS Client on Windows 10 x64, click on add WFS layer and add both layers:

Layer A (Points) adds without problems.

Layer B (Datatble) is not added. I am getting the following error:

2019-06-20T13:27:15     CRITICAL    La capa no es válida : La capa pagingEnabled='true' srsname='EPSG:25830' typename='xxxx_aparcabicis_estado' url='http://xxxx/qgis/qgis_mapserv.fcgi.exe?map=D:%5CInstalado%5COSGeo4W64%5Capps%5Cqgis%5Cbin%5Cgis02%5Cgis02.qgs' version='auto' table="" sql= no es válida y no se puede añadir al mapa. Motivo:

translated to English it should something like:

2019-06-20T13:27:15     CRITICAL    Layer not valid : The layer pagingEnabled='true' srsname='EPSG:25830' typename='xxxx_aparcabicis_estado' url='http://xxxx/qgis/qgis_mapserv.fcgi.exe?map=D:%5CInstalado%5COSGeo4W64%5Capps%5Cqgis%5Cbin%5Cgis02%5Cgis02.qgs' version='auto' table="" sql= is not valid and cannot be added to the map. Reason:

I also get a warning on WFS message box (translated to English by me):

2019-06-20T13:27:15     WARNING    Analysis of DescribeFeatureType response failed for URL pagingEnabled='true' srsname='EPSG:25830' typename='xxxx_aparcabicis_estado' url='http://xxx/qgis/qgis_mapserv.fcgi.exe?map=D:%5CInstalado%5COSGeo4W64%5Capps%5Cqgis%5Cbin%5Cgis02%5Cgis02.qgs' version='auto' table="" sql=: Cannot find the features' attributes

I tried different things so far:

  • Manual request in browser - works
  • Force version to 1.0 / 1.1 / 2.0 in QGIS - no luck
  • Ignore axis orientation in QGIS - no luck

I am planning to migrate from QGIS 2.12 (which can load datatables correctly through WFS protocol) to QGIS 3, but this issue is a red line for me...and I'll have to stay in QGIS 2.12 against my will if this is not fixed or if there is not a workaround...in QGIS 2.12 I can add the datatable without issues...

EDIT 26.06.2019: I opened an issue on QGIS github repo and seems that Alessandro Passoti has fixed the bug and code has been merged to master. I will try it when next version is out!

  • Are the 2 layers somehow connected? Does 1 line in Layer A represent a line in Layer B? And does the data table contain any fields that could represent X,Y coordinates? – Piskr Jun 24 at 13:29
  • @Piskr the datatable (layer B) contains the list of posible values in a text field. I use the Value Relation widget to add the dropdown possibility to the field. – Egidi Jun 24 at 13:37
  • Hmm, this sounds like a problem with the newer version. You could try asking on GitHub. I think it expects the table to have geometry. Are you limited to the WFS protocol? Because you could just connect directly to the postgis database. – Piskr Jun 24 at 13:58
  • @Piskr yes, I need WFS protocol....workers are on daily basis updating on field the data using 4G on a windows tablet – Egidi Jun 24 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.