12

I am trying to use the SEXTANTE module GRASS (and SAGA) for vector analysis but whatever function I use I always get the same error:"Could not load layer: G:/closest.shp Check the SEXTANTE log to look for errors in algorithm execution"

SEXTANTE log says (for "v.distance" module): "Sextante.runalg("grass:v.distance","G:/For QGIS/example_1/point.shp","G:/For QGIS/example_1/point_II.shp",1,"col_name","id",False,False,"G:/closest.shp")"

I get this on three different computers with QGIS 1.8.0., SEXTANTE 1.0.7., updated Win 7.

I think this question is the similar problem: https://gis.stackexchange.com/questions/24895/qgis-sextante-doesnt-create-load-output

closed as off-topic by whyzar, PolyGeo Jan 27 '17 at 22:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Is G:/ writable for you? Maybe the TMP file settings in the plugin are wrong? – markusN Sep 3 '12 at 19:39
  • Yes "G:/" is writable. I get the same error no matter what hard disk or partition is used. – user10016 Sep 6 '12 at 12:28
  • 1
    Is this still an issue after updating to the latest version? – underdark Nov 6 '12 at 19:10
  • 1
    Removing spaces in your path might help - those are known to cause problems sometimes. You can use underscores instead of spaces to test it out, so rename "For QGIS" -> "For_QGIS". – SaultDon Jul 12 '13 at 21:04
  • There can probably be many reasons for your problems. But since your example is v.distance, I would like you to know that v.distance is currently not working through QGIS processing. See gis.stackexchange.com/questions/73575/… – Håvard Tveite Sep 30 '14 at 15:09
2

I get the same type of result when there is no file produced at the end of a process.

In some cases it is because there is no data because I have input the wrong layers or the layers in the wrong order.

In other cases it is because I don't have read / write for all the necessary directories. My installation of QGIS 2.2 has different permissions to my installation of QGIS 2.4 (an IT thing that is irrelevant here). But what that means is that I have two sets of algorithms listed under the Processing Toolbox. They look identical, one set will produce that error because of the permissions, the other will produce a result.

I just need to remember which set will give me a result.

Not the answer you're looking for? Browse other questions tagged or ask your own question.