3

Like the author of GRASS not working with QGIS 3.6, I am unable to use GRASS plugins, with the error:

This algorithm cannot be run :-( The specified GRASS 7 folder "C:\OSGEO4~1\bin\bin" does not contain a valid set of GRASS 7 modules. Please, go to the Processing settings dialog, and check that the GRASS 7 folder is correctly configured

This applies whether or not I start QGIS using the "QGIS Desktop 3.6.3 with GRASS 7.6.1" option or not.

I do not have an option to specify the GRASS path in the Settings > Option > Processing menu.

0

2 Answers 2

2

The way to fix this error is a bit tricky (In earlier versions there was a configuration option to set the path, but for some reasons that has been removed).

First find where your GRASS installation is under the QGIS folder. By default it will be:

C:\OSGeo4W64\apps\grass\grass76

but you need to check and find the exact path.

Now start QGIS and click Settings->Options and go to the Advanced tab. Click the warning button "I will be careful", and then expand (click the small arrow) the Processing -> Configuration item. Scroll down to the Grass7 Folder. Now double click to edit that configuration variable, and set the correct path from your check above. Restart QGIS and you should have access to the GRASS commands.

0

As it turns out the QGIS 3.4.4 version's GRASS tools work, or at least the r.water.outlet tool I was having trouble with.

You can download 8.4.4 from here: https://qgis.org/downloads/

If anyone can make ALL the GRASS tools work in the Pi or Coruna versions please do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.