-2

I'm trying to find the right CRS for a spreadsheet dataset I'm trying to add to my QGIS project. I collected coordinates for wildfire fuels reduction projects using Google Maps, and am hoping to add these points to a map of California that includes administrative boundaries and other relevant data.

I found other threads that say Google Maps uses WGS 1984, but QGIS has a lot of CRS options for WGS 1984 (G1150, G1674, G1762, G730, etc.). How do I find out which one I should be using?

  • 1
    Can you provide a pair of coordinates as an example? – Marcelo Villa Jun 26 at 21:34
  • Do you have latitude and longitude order correct. EPSG:4326 order is lat/long – nmtoken Jun 27 at 5:01
  • Google maps uses EPSG:3857 Web Mercator (read more gis.stackexchange.com/questions/48949/…) which is compatible with WGS84 EPSG:4326, that is to say there is no distortion grid between these two CRS, but to see your data overlaid with Google basemap you need to define your spreadsheet properly, how are you adding the spreadsheet to QGIS? – Michael Stimson Jun 27 at 6:05
  • I'm adding the spreadsheet as delimited text in CSV format. I used UTF-8 encoding, point coordinates where X coordinates correspond with an X coordinate column and Y with a Y column (e.g. 41.487, -120.542). I tried setting geometry CRS to WGS84 EPSG:4326 in the initial import and still can't see any of my points, even when zooming in to the layer. So far my best luck has been EPSG:3310 - NAD83 / California Albers which displays the points in California, but on a very small scale (I have to zoom into a small corner to see the points, although they should cover a large portion of the state). – Devin Jun 27 at 6:52
  • 1
    @FSimardGIS That did it! Thank you so much for the help. – Devin Jun 27 at 12:39
2

If you pulled the coordinates from Google Maps by copying the lat/lon pairs then chances are you can use EPSG:4326 and your data should display fine.

  • That doesn't seem to work. When I try EPSG:4326, and many other CRS, I can't see any points at all even when I try zooming to the layer or zooming in and out. Do you have any other suggestions? – Devin Jun 26 at 21:44
  • Try heading your y column as Latitude and the X column as Longitude. QGIS should recognize them automatically this way when you add the delimited text file. Make sure you are selecting the "Point Coordinates" option during upload. – Kingfisher Jun 27 at 14:04
1

The number after WGS 84 indicates GPS week number. I believe you should be using, WGS84(G1762).

See details about it here

  • Thank you for clarifying that I'm looking at the week number--I was wondering what the difference between all the options was. That still doesn't seem to work though. When I try WGS84(G1762), and many other CRS, I can't see any points at all even when I try zooming to the layer or zooming in and out. Do you have any other suggestions? – Devin Jun 26 at 21:45
1

It appears that your X and Y values were reversed. X is Longitude and Y is Latitude, i.e. 41.487 should be a Y coordinate, and -120.542 should be the X coordinate. Doing it the other way around sends the points at a latitude of -120°, which is outside the valid range of latitudes.

41.487, -120.542 falls in Alturas, CA. It is a valid coordinate pair, and appears to be geographic coordinates in WGS84 (epsg 4326). If you define your points in that system it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.