I have a web map that has been created on ArcGIS Portal. Our Portal is federated. The feature layer (service) and web map have all the required settings based on the documentation of ArcGIS Collector app. When logged in to the ArcGIS Collector app on iPhone (iOS), we can see the webmap and collect points, the problem is we can't attach pictures. When we take a picture for the collected point and click "Submit", the following error occurs: "Update Failed: 1 attachment could not be sent".

We are using the Classic Collector app, however, I also tried downloading the new version, the same error occurs.

I've tried to simulate the same workflow over Blue Stacks (android) Collector on PC, and everything seems to be working and attachments uploading to the web map.

I also have tried my ArcGIS Online account with another web map where I tried to attach a photo using my iPhone and Collector app, it also worked perfectly without giving me any errors.

However, we must get it to work on ArcGIS Portal for my team, as we don't have access to additional ArcGIS Online user accounts right now, and probably, there should be no issue like this working wherever...

Anyone had this problem or has any idea what could have gone wrong?

Attached you will find an error screenshot from iPhone, and also what the ArcGIS Server Manager puts as a Warning when we try to attach a photo.

enter image description here enter image description here

  • Have you researched SE? I found these 1, 2, 3.
    – Hornbydd
    Commented Jun 27, 2019 at 9:46
  • Hello @Hornbydd. Yes, I did. Our problem is not the same as the ones you found, because: it is not issue uploading multiple attachments, even one attachment upload isn't working. it is also not issue with ArcGIS Online, but with ArcGIS Portal. IThe problem is also not about data loss, but about failing to add attachments. I haven't seen any posts about working on Collector with web maps from ArcGIS Portal before. I did a good Google search before posting my problem. Hope this clariefies. Commented Jun 27, 2019 at 11:14
  • Did anyone figure this out? we're having the same issue in portal on ios only. wild thing is that it works on android and windows on the same map and in the same portal, so it's not a map or portal issue directly. however, we have several crews out using iPad pros with no issues on different maps, so maybe it's a map issue.
    – Zach
    Commented Mar 16, 2020 at 13:24
  • @Zach see my answer below . Commented Mar 18, 2020 at 6:46

1 Answer 1


We fixed this issue last month! Esri sent us a link where we could follow guidelines and our ArcGIS admin installed the patch (see the attached photo).


However, after installing the patch, it is important to do the following to enable attachments working with iPhone on Collector in ArcGIS Portal:

Note: For pre-existing services, an update must be made to the service configuration in order for the fix to kick in. One way to do this is to disable and then re-enable editing and save via the Enable editing checkbox on the feature layer's item page in Enterprise. This step is not needed for services created after installing the patch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.