I set up a new SDE database with ArcGIS 10 and everything appeared to go correctly. The service is running and I'm able to view the database in SQL Server.

However, when I try to access the spatial database connection in ArcCatalog 10, I get the following error:

Failed to connection to the specified server. This release of the GeoDatabase is either invalid or out of date. DBMS table not found [Microsoft SQL Server Native Client 10.0: Invalid object name 'sde_mymap.dbo.GDB_Release'.] [sde_mymap.dbo.GDB_Release]

Both ArcSDE and ArcCatalog are version 10.

I checked the sde_setup.log file and I can find no record of that table being created, or any other errors.

Please advise.

Thanks, Seth

  • what process did you use to create the db? It sounds like you have sql server with spatial (do you view the data table or the map in sql server?). perhaps you could create a new db in catalog and verify that is working correctly. Have you checked the webhelp for this step? help.arcgis.com/en/geodatabase/10.0/admin_cmds/Support_files/…
    – Brad Nesom
    Nov 8, 2010 at 15:24
  • I used the ArcSDE for Microsoft SQL Server Post Installation to create the GeoDatabase. I was not able to create the Database Server in ArcCatalog because I am using SQL Server 2008 R2 instead of Express. Nov 8, 2010 at 15:49
  • I have found that SQL Server 2008 R2 has some issues depending on the Operating System of the Database Server. What Operating System is the server?
    – CDBrown
    Dec 6, 2010 at 7:59
  • @CDBrown Windows Server 2008 R2 Standard Dec 6, 2010 at 13:55

2 Answers 2


Here is how I got around this issue

  1. Uninstall ArcSDE
  2. Detach all Databases
  3. Uninstall SQL Server R2
  4. Install SQL Server
  5. Install ArcSDE

The issue is this, SQL Server 2008 R2 is not a support DB, as the SQL Server Native Client built into ArcGIS was released prior to the release of R2. Here is a link


Update: Have you tried making a Direct Connection to your database. This can be done by creating a new Spatial Database Connection in ArcCatalog. Next type the following deatils

Server: leave blank Service: sde:sqlserver: Database: leave blank Please let me know if it works

Sorry for the bad news, CDB


I stumbled on this thread when I ran into a similar GDB_Release table not found issue with ArcSDE 10.2.2 and SQL express. I just wanted to post what worked for me. In my case, simply stopping and starting the database in ArcCatalog fixed it.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .