2

I am having an issue with GRASS i.landsat.toar tool. It will not let me choose my metadata .txt file. I click on the three dots to the right of "Name of Landsat metadata file (.met or MTL.txt) [optional]" (image 1). I browse to where my metadata is stored (image 2), but it is not there. The only option for file selection is .met. I look in my folder and the MTL.txt file is clearly there (image 3). I do not understand why QGIS will not let me pick the .txt file type (image 2)? I am using QGIS 3.6.3 with GRASS 7.6.1

enter image description here

enter image description here

enter image description here

Edits:

I installed QGIS 3.4.9 with GRASS 7.6.1 and was able to select all files to grab the MTL.txt file. Though I recieve the error "Wrong or missing parameter value: Name of Landsat metadata file (.met or MTL.txt)". So it seems that it is not reading my MTL.txt file correctly?

1

You can change the file extension from MET Files (*.met) to All files (*.*)

enter image description here

and then choose the MTL.txt file from the available files

enter image description here

I am using QGIS 3.4.5.

  • I edited my original post (image 2). I do not have the option to select "All files(.)" – Zman3 Jul 1 at 5:27
  • @Zman3 Try to use QGIS 3.4.9 LTR maybe it will solve the issue. – ahmadhanb Jul 1 at 8:11
  • I just did, and I can get to the file, but there is still an error with the file. See additional edits. – Zman3 Jul 1 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.