1

I am using QGIS 3.4.8.

I'm working on a project and the projection is in EPSG:2772-NAD83(HARN)/Colorado North and the Ellipsoid is GRS 1980(IUGG,1980). I received a some new shapefiles for the project that are in EPSG:2231-NAD83/Colorado North (ftUS). When I add the layer to the project, it drops it about 1000 ft to the northeast of where it should be. So, I run the Reproject tool to change it to the project's projection but it doesn't move the feature - it just creates a new layer that is in the same exact spot.

I tried right-clicking on the layer to Set CRS and choose the projection I want, it feature moves to somewhere north of Ottawa, Canada (my project is in Colorado).

There is also this projection that was in the dropdown for choosing a CRS, * Generated CRS (+proj=lcc +lat_1=39.71666666666667 +lat_2=40.78333333333333 +lat_0=39.33333333333334 +lon_0=-105.5 +x_0=914401.8288999998 +y_0=304800.6096000001 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=us-ft +no_defs) somehow associated with the shapefile that puts the layer in the same place as the EPSG:2231-NAD83/Colorado North (ftUS) projection.

Any thoughts on what's going on here?

  • 1
    Maybe the data is just off by 1000 ft? – Erik Jul 3 at 14:49
  • Is there a way to fix this? – Jdimaria Jul 3 at 14:50
  • Yeah, get correct data, ideally not in a fancy CRS but something basic like EPSG:4326 or an UTM-Zone fitting your area. – Erik Jul 3 at 15:01
  • 1
    The Reproject tool generally isn't going to move your data much, if at all. It is designed to leave data in the same place but change the projection (e.g., WGS 84 to UTM). Usually if a shapefile doesn't fall in the right location it has the wrong coordinate system selected, but is really projected in something else. Right click and Set CRS to the correct projection. This can be a little bit of a guessing game though, unless you can contact the person who made the data and ask what it should be. I run into this problem all the time when I get data from contractors. – lambertj Jul 3 at 15:17
  • 2
    The data is coming from a CAD export to shapefile from a contractor. I've had these issues in the past and it appears that it isn't something that I can fix on my end. It seems like files are drafted in some abstract projection in CAD and there are always projection issues when the files are exported to shapefile, even when I request a specific projection. – Jdimaria Jul 3 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.