3

How do I change the text size in the attribute table or the height of the rows in QGIS?

  • Please edit your question to include a full description of the problem that you are trying to solve. Include screenshots to help explain the issue. – Midavalo Jul 4 at 17:22
3

As far as I know, there is no an option in QGIS to change only the text size of the attribute table. Therefore, I suggest you to add a new theme to change font size of attribute table. To do that:

  • open QGIS profile folder (Settings -> User Profiles -> Open Active Profile Folder).
  • navigate themes folder and create a folder and name it (i.e. My Theme).
  • navigate the folder and create a file named style.qss.

enter image description here

  • open that file in any text editor, add the following lines and save it. (You can change the values into what you desire)
#AttributeTable QTableView{
    font-size: 20pt; /* font size for attribute values in the table */
}

#AttributeTable QTableView QHeaderView{        
    font-size: 40pt; /* font size for left and top header names */
}
  • open Settings -> Options.... In General tab, choose My Theme as UI Theme. And re-open QGIS.

enter image description here

RESULT:

enter image description here

  • Hi, thanks for your advice, but it doesn´t work. I use notepad++ to create the style.qss file and copy/paste your code in this file. The file is in the right folder and I can choose the ui "my themes" in the options of qgis. But the size of my text doesn´t change. – joe_gerner Jul 10 at 5:46
  • I use QGIS version 3.4.8 – joe_gerner Jul 10 at 6:04
  • It works, I found my fault. Thank you very much for your help – joe_gerner Jul 11 at 13:06
6

You can adjust the text size (for the whole of QGIS) in the Settings->Options menu.

enter image description here

giving (at 20pt):

enter image description here

  • thanks for your advice, but is it also possible to change only the text size of the attributetable? – joe_gerner Jul 4 at 8:30
  • I don't believe so – Ian Turton Jul 4 at 8:30
  • 3
    It's possible. I will add an answer as soon as possible. – Kadir Şahbaz Jul 4 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.