2

Have a geo-referenced map and a delimited text file with coordinates of points to plot over top of the map.

Issue is that the points are displaying far down and left of the map. Clicking on them shows the lat and long are correct, but the derived coordinates are not.

Attempted to change the CRS for both the map and points, though did not find a combination that worked. Currently leave both on the same CRS of EPSG:3400 which seems to be reasonable.

Also approached the issue by changing settings during importing the delimited text layer, did not find anything wrong with it.

Adding more points with different coordinates resulted in the same issue, the coordinates being in close vicinity, far down and left of the map.

The map is accurate, and while hovering over the city of Calgary the coordinates displayed on the screen are reasonable and where the points should be.

Hoping to hear what could be causing this issue of the points mapping to the wrong locations, and a solution that they appear where expected.

Using QGIS 3.4

map and points with incorrect coordinates delimited text file with coordinates settings of adding layer delimited text

1

Your point -114.0631 51.04430 (here in longitude-latitude order) is obviously in EPSG:4326. If you want to plot that point on top of map that is in EPSG:3400 you must transform the coordinates into EPSG:3400 as well. You can do that with for example gdaltransform utility.

gdaltransform -s_srs epsg:4326 -t_srs epsg:3400
-114.0631 51.04430
565652.381906514 5652905.85791649 6.33029267191887e-05

Now plot the converted coordinates on a map

enter image description here

Map generated with URL https://epsg.io/map#srs=3400&x=565652&y=5652905&z=17&layer=streets

QGIS should put the point into correct place is you define the SRS of the raster map into EPSG:3400 and the CSV layer into EPSG:4326.

  • Thanks! Defining the CRS of the CSV text layer to EPSG:4326 and keeping the CRS of the map as EPSG:3400 maps the points perfectly on the map. Happy that it means the coordinates do not have to be converted. – mkrc Jul 4 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.