1

I am a new user to ArcGIS Desktop 10.7. I imported data table from Excel 97-2003 format in the Table of Content. Then with XY recognition the layer was created with the defined coordinate system. The layer shows all the attributes but in the attribute table "Add Field" option does not show up. Also 'delete field', 'Calculate Geometry' and 2 other options don't activate. I tried to export the layer file to a shapefile and after the shapefile is created it does not show any attribute table.

Could anyone suggest a way to address this issue?

All I need to do is add field.

  • Can you use the Add Field tool from the toolbox resources.arcgis.com/en/help/main/10.2/index.html#//… ? Do you have 'add field' available for other feature classes? If not you may need to uninstall/reinstall ArcGIS. Have you got the Excel spreadsheet open in Excel? Excel will lock the table not allowing changes to be made. Are you using ArcGIS Desktop or ArcGIS Pro? – Michael Stimson Jul 4 at 23:53
  • Hello Michael. It is very kind of you to reply. I have 'add field' option available for other layer file. What I did was I was given a file, I copied the attribute table to excel and then filtered data, saved in the 97-2003 workbook and tried to import it by add data option of Arcmap. I am using the desktop version. The main file's attribute table is working and is in the same content table. As I am not from a CS background I tried to avoid the SQL attribute selection and tried the excel filtering. Thank you for the patience. – pranesh biswas Jul 5 at 0:10
3

From Understanding how to use Microsoft Excel files in ArcGIS:

Excel tables are read-only in ArcGIS as well as in Excel when you have a workbook open in ArcGIS.

Consequently, you will not be able to add a field to one, delete a field from one or calculate geometry in one, unless you export that Excel worksheet as a geodatabase (or DBF) table.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.