2

Qfield cannot load GeoPackage raster data exported with Qgis 3.8.0. Download vector data from the gpkg file. The test with a single raster file in a GeoPackage also failed.

  • 2
    Achtung, es folgt Werbung: Schau dir bitte mal DeepL an für solche Fälle. - Attention, advertisement: Please have a look at DeepL. – Erik Jul 5 '19 at 13:19
1

If you drag and drop the geopackage raster from a file browser into QGIS (and not open it from internally), this helps to store the path as a relative path inside the QGIS project file.

| improve this answer | |
  • i have the same problem, your solution did not work unfortunately (i drag&dropped the rasterpics from QGIS browser into the layer overview but it did not change anything :/ ) – sn1ks Aug 19 '19 at 10:57
  • 1
    Can you try doing that from a "file browser" instead of the QGIS browser? – Matthias Kuhn Aug 19 '19 at 12:21
  • i dropped the gpkg containing two orthophotos and a point layer from windows file explorer into qgis layer control, with same result. when i want to export that project, it says several layers are not configured, when i go to configure the (QField) project, i have only the options "no action" and "remove" for the orthophotos – sn1ks Aug 19 '19 at 12:45
  • And what happens if you do "no action"? – Matthias Kuhn Aug 19 '19 at 12:51
  • 1
    when i open the .qgs file with a text editor, it saves the full path (and not the relative one). another difference i observed is that it is using a different seperator for the layer. the working (point layer) goes: (...).gpkg|layername=(...) the non working raster goes: (...)gpkg:Orthofoto1" – sn1ks Aug 19 '19 at 12:51
0

For some reason qfield does not understand relative path in .gpkg rasters. My workaround was to create exactly same path of qfield project in my Linux machine (/sdcard/Android/data...). Might it be same case for you?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.