We have just upgraded from ArcGIS Desktop 9.2 to 9.3.1

For a ~250MB .shp in 9.2 it took 1 minute to render, at 9.3.1 it now takes 50 minutes.

  • The format has to stay as shapefile.
  • The data is stored on both NetApp and Dell Servers - problem consistent on both.
  • Only an issue with GIS data, in particular shapefiles and only in 9.3.1.
  • Have already have tested during the day and night and the times returned are consistent showing that network traffic is having no or very little effect on the poor performance.
  • Also tested on servers that do not have virus protection to eliminate that from the equation.
  • Already tried testing on several servers with differing switches (100Mbit and 1Gbit) but the results have been the same.
  • Have tested on a newly built pc with a vanilla install of ArcGIS so it can’t be incorrectly uninstalled components or third party products causing the issue.

I am putting together some further test-cases to carry out, to try and pinpoint the problem further before taking it to Esri:

  • Run the tests at 9.2 with a large ESRI sample dataset. Run tests with it as a shp and as a file GDB.
  • Re-test with 9.3.1 (+SPs) and again with v10
  • Run tests in both ArcMap, ArcGIS Explorer and ArcReader (to see if it is specific to an application)
  • Compare these results with how long it takes to open when stored locally?

From what I know, there have not been any changes made to the underlying code and the way that ArcGIS connects to a network between 9.3.1 and 9.2. I also don't think that Esri changed anything in the way that ArcGIS reads shapefiles between these versions?

Other than the above, the only other suggestion I can think of is to run WireShark to try and see how long it takes to send/receive packets from the client machine & the server.

This will tell me two things:

1) How many packets are going both directions

2) how long each packet takes to be transmitted.

My thinking is, if it is related to 9.3.1, then you would most likely see an increase in the number of packets. It could be a security configuration that at 9.3.1 we have encountered, but at 9.2 we did not. It would be best to capture a wireshark trace for both 9.2 and 9.3.1 accessing the same shape file on the same server.

Has anyone experienced anything similar to this?

Does anyone have any other ideas on how to troubleshoot this?

3 Answers 3


We had this as well unfortunately - I believe it is a known bug. The only way around it we found was to clone data across the network to a local drive, but that isn't much of a solution I know. It has been fixed in 10 however...

Found two possible solutions on the ESRI forum - the one that worked for us was to look at the registry settings, as shown here (it reduced the draw speed from a large mxd from ~3mins to <10 secs).

Alternatively you could try manually building a spatial index on your shapefiles, as explained here.

And the ESRI bug report, which mentions the issue, but not much in the way of fixing it.

Hope this helps!

  • Thats great to hear. Would really really appreciate it if you could provide a NIM or anything you have from ESRI. If need be, you can send it to me via email.
    – jakc
    Commented Nov 7, 2010 at 12:03
  • Updated with some of the forum posts we used to get around the performance issues. I'll look later this afternoon to see if I can find the actual bug report.
    – om_henners
    Commented Nov 7, 2010 at 22:18
  • Thanks for that. That registry change looks interesting. Ill try and test that on Thursday. Ill report back my findings...
    – jakc
    Commented Nov 8, 2010 at 4:23
  • That registry setting was it! Saved me a lot of time here. Thanks for your help. support.microsoft.com/default.aspx?scid=kb;en-us;Q296264
    – jakc
    Commented Nov 11, 2010 at 3:44

try this:

create a geodatabase in 9.3.1 (file or personal, it doesn't matter), import the shapes into it and then export them into shapefile format again, in 9.3.1

this corrected the problem when i came across it.

  • I will try this. However, what actually happens here? Surely the shp format itself has not changed between 9.2 and 9.3.1, and what benefit/changes happen when you import the data to a GDB and then export it back to shp? There is no change to the geometric/attribute info?
    – jakc
    Commented Nov 10, 2010 at 12:02

Maybe your shape files are missing spatial index. You check this in ArcCatalog - right click the shape file -> Properties -> Indexes tab. If the Add button is active, your shape file is missing spatial index. Simply press Add to assign an spatial index to the shape file. Spatial index greatly improves the performance, and is automaticly added in Geodatabases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.