When I work on a polygonal layer, I turn on 'Topological Editing' from the snapping toolbar, which allows moving the nodes from adjacent polygons together.

Everything works fine until I add any underlay from the QuickMapServices plugin - Google maps, OSM etc.

After any such layer is added, only individual vertices are selected. So, in order to move a node I have to move individual vertices from neighbouring polygons. The 'topological editing' button is still 'pressed' - no changes in the snapping toolbar.

The problem persists even when I remove the underlay.

How can I keep Topological Editing functional with the google/osm map enabled?

1 Answer 1


When you add a basemap, sometimes the project CRS switches automatically to match the CRS of the basemap. I don't see any reason it would cause the issue you describe, but that's the main thing I can think of that can change when you add a basemap.

I was able to reproduce your issue by changing the project CRS. The issue resolves when I change the project CRS back to the same CRS as the layer I'm trying to edit with topology.

After adding a base map, change the project CRS to match the CRS of the layer you're editing.

Based on my testing, it seems like the topological editing feature only works on a layer when project CRS matches the layer CRS. I couldn't find any documentation to support this assertion, but the documentation for the topological editing tool is not very detailed.


To prevent this (unwanted) behaviour there's also a checkmark in QuickMapServices Settings:

"Enable OTF EPSG:3857 on tiled layer add:" which should be disabled. enter image description here

  • Thanks for the update. I forgot there was a setting for that.
    – csk
    Jul 10, 2019 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.