0

I am trying to upload some gpx data (GPX XML format) to a Garmin GPSmap 60CSx unit using the gpsbabel (v.1.5.4) command line interface for Linux (Ubuntu 18.04).

I followed instructions from the gpsbabel website https://www.gpsbabel.org/htmldoc-development/fmt_garmin.html. Specifically, to test the connectivity I tried to download data from the GPS device into a gpx file, using the command

gpsbabel -i garmin -f usb: -o gpx -F blah.gpx

This worked fine so I then tried to do the opposite using the command

gpsbabel -D1 -i gpx -f Olympos.gpx -o garmin -F usb:

but no tracks and/or waypoints appeared in the unit after the transfer was complete. The USB default unit is identified correctly

gpsbabel -o garmin -F usb:-1

returned

0 3352480812 292 GPSMap60CSX Software Version 4.00

then using usb:0 or usb: as output device and debug output enabled in command line I see no error :

GPSBabel Version: 1.5.4 
options: module/option=value: gpx/snlen="32" (=default)
Unit:   GPSMap60CSX Software Version 4.00
ID: 292
Version:    4.00
Capability A10:
Capability A100: D110
Capability A201: D202 D110 D210
Capability A301: D312 D302
Capability A400: D110
Capability A500: D501
Capability A600: D600
Capability A601: D601
Capability A700: D700
Capability A800: D800
Capability A801: D801
Capability A900:
Capability A902:
Capability A903:
Capability A904:
Capability A905: D900
Capability A907: D907 D908 D909 D910
Capability A908: D911
Capability A914:
Capability A916:
Capability A917: D917
Capability A918: D918
Capability A1010:
Capability A1011:
Link_type 1  Device_command 0
Waypoint: Transfer 100 Type 110
Route:    Transfer 201 Header 202 Type 110
Track:    Transfer 301 Type 302
Waypoint type: 110
Chosen waypoint length 14
cet_util: Converting from "UTF-8" to "US-ASCII", done.

what could be wrong ? Is transferring to the device supported ?

2
  • Hi would be great to know if you had any success resolving this. Suffering same issue :-(
    – John
    Oct 13, 2019 at 9:47
  • Hi @John yes the problem was that I did not use the correct arguments. at least one of "-w" [on by default], "-r", "-t" must be present to process the corresponding information. Do be careful , sometimes waypoint info may be embedded in tracks and so only "-t" would actually do the copy.
    – nass
    Oct 15, 2019 at 8:29

2 Answers 2

0

As commented by the asker:

... the problem was that I did not use the correct arguments. at least one of "-w" [on by default], "-r", "-t" must be present to process the corresponding information. Do be careful , sometimes waypoint info may be embedded in tracks and so only "-t" would actually do the copy.

0

sudo usermod -a -G dialout $USER

1
  • 1
    Welcome to GIS SE. As a new user, please take the Tour. We are looking for Answers which not only tell what so do, but explain why, citing documentation and/or giving a justification on why the comma and should be used.
    – Vince
    May 8, 2023 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.