1

I'm new to GRASS and in the past I have had no issue installing add-ons. Recently I tried to install "r.stream.order" and got the following error:

g.extension extension="r.stream.order"

Extension r.stream.order not found

I have tried installing the add-on both through the shell and the GRASS GUI. I have also downloaded the zipped file and tried to use the url option with the g.extension tool to install the add-on, but I get the same error. Although, this may have failed because the url option is supported only on Linux or Mac.

g.extension extension="r.stream.order" url=C:\Downloads\r.stream.order.zip

I read that the add-ons are installed by default from the GRASS SVN repository, which has recently been migrated to github and the svn repo now has read-only access.

Has anyone run into this error recently? If read only access to the SVN is causing the error, does anyone have any recommendations for how to resolve this issue and install the add-on?

Note: I have GRASS 7.6 installed on a Windows computer.

UPDATE: The add-on installs correctly on my personal computer with version 7.2 of GRASS. However, installing this same version on my desktop still produces the error. Additionally, installing newer versions of GRASS on my personal computer also produces the "extension not found error".

  • Please use text instead of images for commands and errors. This makes them legible on all devices and free-text searchable by others. – Vince Jul 10 at 23:56
  • Thank you. I've replaced the image with text. – BBourdages Jul 11 at 0:01
0

This is due to the server url being different to the one hardcoded in grass. See this ticket for some details, https://trac.osgeo.org/grass/ticket/3455 and also this question GRASS GIS addon "extension not found"; could the problem be with the GRASS Addons server?.

A workaround is to locate the g.extension.py script, copy and rename it and modify one line (search for cz). (You'll need an editor like Notepad++ to avoid issues with carriage returns). Then run using File > Launch Script.

base_url = "http://wingrass.fsv.cvut.cz/" \
           "grass%(major)s%(minor)s/%(platform)s/addons/" \
           "grass-%(major)s.%(minor)s.%(patch)s" % \
           {'platform': platform,
            'major': version[0], 'minor': version[1],
            #'patch': version[2]} # comment this out
            'patch': 'svn'} # add this
  • Thank you! That worked for downloading the extensions/addons. However, now I get this error: ERROR: Module built against version $Revision$ but trying to use version $Revision: 72327 $. You need to rebuild GRASS GIS or untangle multiple installations. I'm still looking into it, but i anyone has any ideas how to fix this, I would be incredibly grateful! – BBourdages Jul 26 at 18:25
  • The C addons are complied against a version of grass. Check the version of grass you have installed and maybe consider upgrading before installing addons. – vinh Jul 31 at 14:22
  • It shall soon be all fixed. We are working on it (and yes, it is annoying!). – markusN Aug 6 at 6:16
  • This is great to hear! It seems like some extensions are working (ex. r.hazard.flood), but others are not, like r.area, which is needed for the flood hazard module. sigh Any idea how soon, "soon", is? ;) – BBourdages Aug 8 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.