2

In the screenshots of shapefiles in this question, Accessing downloaded shapefiles/attribute data?, you can see that the .shp files have the QGIS logo as its icon.

I think this means that on that particular computer, someone tried to open a .shp file directly, Windows asked them what program to use, and they chose QGIS as the default program to open that type of file.

enter image description here

Now, that user is having some unusual difficulties getting shapefiles to properly load into QGIS. Polygon shapefiles are loading into QGIS as point layers with no data in them. I wonder if these problems be related to having QGIS set as the default program to open a .shp file.

I don't want to take the risk of testing this out myself, in case it causes the same problems on my computer. Hopefully someone out there has seen this done before.

So my question is: If you've ever set QGIS as the default program to open a *.SHP file, did it cause any problems?

Eg, shapefile corruption, causing QGIS to misinterpret the data type, etc.

  • Don't know about windows but it's fine on Linux – Ian Turton Jul 12 at 18:56
  • 4
    The link between the default application to open a file type and issues when opening a file through the application itself sounds highly unlikely. The first one is a system setting which is normally not involved when the second one is done. I guess you verified that the same files that don't open on his computer work fine on other computers? – Matthias Kuhn Jul 12 at 19:14
  • I agree that the link seems unlikely, but I still wanted to look into it. As I mentioned it would be easy to test, except that one possible outcome of that test is to cause the same problem on my computer. And yes, the same GADM files that don't work on their computer do work on my computer. I'm also thinking it could be a problem with their unzipping program, or a firewall issue, or something else related to the downloading process. – csk Jul 12 at 19:49
  • Just wondering - if you open the shapefile through QGIS (layer > add layer > add vector layer) do you still get the same error? – Chris Jenner Jul 15 at 15:29
  • @ChrisJenner I'm not the one having the errors I described here. You can see more details if you visit the linked question. That person had some unusual errors, and at this point they're still unexplained. – csk Jul 15 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.