0

I've got a POI layer (vector layer with single-point geometry) in QGIS and would like to import these points to OSMAnd under "My Locations" including the attributes (like name of the point). How can I do that?

I tried SQLite, GeoPackage and GeoJSON, but always got two errors:

  1. Firstly, OSMAnd complains that the layer does not contain waypoints and asks if I want to import it as track.
  2. If I confirm, it then shows an error message like "Unexpected token (position: TEXT ...".
1

Eventually, I was able to import the POIs into OSMAnd as GPX format. However, it was necessary to enable the GPX_USE_EXTENSIONS when exporting it in QGIS in order to allow OSMAnd to import the string attributes properly.

  • I was just checking myself but nice, I am glad you solved it yourself :) – Ruben FV Jul 16 at 8:18
  • Many thanks for your help anyways! – fuggi Jul 16 at 19:40
0

I think you should try to export to GPX (GPS eXchange) Format.

Check this: Importing GPX in OSMAnd.

  • Sorry, I forgot to mention that I tried it, but could not export the attributes with the points. – fuggi Jul 15 at 19:57
  • Can you provide more information about your data in order to have a better idea where the problem lies? – Ruben FV Jul 16 at 6:18
  • How does the original/exported attribute table looks like? How many / which type of attributes do they have? – Ruben FV Jul 16 at 6:19
  • There are 4 attributes, 3 of them are strings and 1 is an integer (UID). I don't care about the UID, but need to transfer at least the names (one of the string attributes). – fuggi Jul 16 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.