1

I had Qgis 3.4 running well on my PC Windows 10, 64 bit. I tried to upgrade to Qgis 3.8 Zanzibar and I had the error message: ''Qgis_app.dll is missing check runtime environment check C:\OSGEO4W64\bin\qgis-dev-bin-g.exe''.

So far, I tried the folowwing:

  • install countless times with OSGEO
  • install from OSGeo and direct download, the 3.8 don't work
  • go back to the older 3.4 version (from OSGEO or direct donwload), it didn't work
  • run the from the qgis.bat file
  • installed qgis 3.4 as administrator
  • copy and paste the qgis.bat.temp and change the name to qgis.bat
  • Tried to change the path of OSGeo in the .bat file, but I was a little bit lost...?

OSgeo4W shell does not launch from my start menu either, instead I have a text file opening with a text editor software. Grass Gis 7.2 doesn't work also, I also have a text file opening with a text editor software.

Funnily, I have two folders created for QGIS (or I believe so, but I'm not sure):

C:\OSGeo4W64\bin

and:

C:\Program Files\QGIS 3.8\bin

Could this be one of the reason? Should I append one of the path file, if yes, how should I do it?

3
  • 1
    this is a common problem,try uninstalling all qgis versions and install QGIS 3.8 from OSGeo4W – Fran Raga Jul 15 '19 at 10:28
  • Thanks for the suggestion @FranRaga, I tried it, however it returned the same error message (qgis_app.dll is missing etc.) – Mel Jul 15 '19 at 23:13
  • So I tried to delete absolutely all my qgis files (including from other session) from my laptop and the C:/drive and do clean start-up with OSGEO. It didn't work. I had the following 4 messages after the install with OSGEO: ''package qgis ltr: qgis-ltr.bat exit code 255''; ''qgis-ltr-comm.bat exit code 255''; '' qgis-ltr-dev.bat exit code 255 '' and; ''qgis-ltr-grass-plugin7.bat exit code 255'' . Any idea? – Mel Jul 17 '19 at 9:27
1

I just had this error when trying to start QGIS 3.12.1 through double-clicking on a shp in Windows explorer. I still had old folders for QGIS 3.4 and 3.8, but I'm not sure if that's relevant. Anyway, I deleted those older folders and ran the 3.12.1-installer again. It uninstalled and reinstalled QGIS 3.12.1 and it could now successfully start.

-1

Check your Windows Environmental Variables. • Control Panel\All Control Panel Items\System > Advanced System Settings. Both the "user" and "system" variables may be pointing to older QGIS paths. e.g. C:\Program Files\QGIS 3.06\bin\

Tested:: No, that doesn't fix the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.