I have a problem with ArcGIS Server 10.2.2 Cache displaying (cache format: Compact, JPEG, 256x259 tile, 96dpi, total levels 12) The problem is that after a crash event (as an example of an unexpected failure of the power network), not all of the areas in the Cache are displayed at service, and some areas of the area are not displayed at different scales. The only solution that helps to make things work correctly is to change the Cache location as an example: from C: // ServerCache, to C: // Servercache2. (Deleting a service and rebooting in the same name does not work). ArcGIS Server Clear Cache REST dir also does not help. I add a video to understand my problem more clearly https://streamable.com/ko617

  • If your server was corrupted by a power loss event you need a more reliable operating system, not different GIS procedures. – Vince Jul 15 '19 at 11:11
  • I don't think the server was corrupted, why then resolving the cache directory location fixes the problem? But for me, this change is not appropriate for finding out why it does so, there are other services for the same trouble. – ru-ubuntu Jul 15 '19 at 13:26
  • If it stopped working, it was corrupted. The corruption diagnosis is supported by incomplete function. Clobbering parts of the install to get nominal functionality back is not the same at retaining full functionality. Usually the review of the corruption would be a Tech Support task, but 10.2.2 was retired from support two weeks ago, so you don't have many options besides your full backup from before the data loss event or rebuilding the service cache from scratch. – Vince Jul 15 '19 at 16:19
  • if the cache would be corrupted, the result would be to move it to another directory, but now it works well – ru-ubuntu Jul 16 '19 at 7:11
  • one good person suggested to me : Please apply the following patch. This should resolve this issue. ArcGIS 10.2.2 for Server Map Cache Consumption Patch support.esri.com/en/products/enterprise/arcgis-server/… – ru-ubuntu Aug 28 '19 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.