0

I'm having a problem with editing features within a file geodatabase. After drawing a feature and saving it, the feature will disappear from the data frame and the attribute table simultaneously. If I restart ArcMap, the feature might reappear, but most of the time I get a fatal error that the data can no longer be loaded from the data source.

Error after saving editsError after restarting ArcMap

This error occurs on all feature types and first appeared in 10.5.1 but has persisted across a clean install of 10.6.1. It occurs within populated geodatabases as well as within completely empty ones (as seen in the images).

The geodatabase was built by a GIS committee in my organization and has numerous domains and attributes, so building a new one from scratch by myself is impractical. Instead, I have made several attempts at creating a new geodatabase by exporting/importing the features, exporting/importing the schema to/from an XML workspace, and simply copying/pasting the empty geodatabase template. I've also tried deleting and re-adding spatial indices.

I've scoured the Web for answers or clues and have come up with very little. This question has been asked here on Stack Exchange but no one gave an answer. I've brought this issue to the attention of the GIS listserve I belong to at work, but again, nobody had an answer.

UPDATE: I've pinpointed where the error initially occurs and it seems to be after I project the feature datasets into a coordinate system that differs from 1) the coordinate system of the original GDB and 2) the points data collected in the field that I use as guides for drawing polygons. Is there a workaround for this?

  • 2
    Does your layer contain a definition query which would prohibit the viewing of the feature? Have you tried loading the feature class directly into a blank map? Also, the error on the second image looks like it's running a python script of some type. Do you have custom tools which may be the cause of the problem? – Fezter Jul 15 at 23:03
  • Have you logged a job with ESRI? my.esri.com – Son of a Beach Jul 15 at 23:09
  • Do your layers contain label expressions that are out of date after a schema change, like a field name change. Are you running Attribute Assistant with an out of date expression? As mentioned by @Fezter, a python script is being fired somehow that contains an unhandled exception that could create a memory issue or feature class lock that is not being released. – Richard Fairhurst Jul 15 at 23:16
  • Thank you for the clarifying questions. I don't have any definition queries; I have used a blank .mxd; I'm not running any expressions or Python scripts. I have also gone through the trouble of projecting the various datasets into the same projection. What you're seeing in the second image is the name of a layer (a standard developed by the aforementioned committee) and the observation made by @Fezter makes me wonder if the final two characters in the FC name is causing a problem. – DLCurtis Jul 15 at 23:48
  • Oh, that's a feature class name? That shouldn't matter. I've used that abbreviation before for polygon features. I assumed it was a .py file. – Fezter Jul 16 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.