I try to use the georeferencer to geofreference certain building plans, but the referencer really distorts colours:

enter image description here

As you can see in the picture. it hollows out what used to be solid red, black and blue letters and dashed lines.

How can this be fixed?

It occurs with pdf as well as images.


enter image description here

Also occurs with use 0 for transparency disabled, helmert transformation, cubic resampling and no image enhancing.

  • 2
    can you add the unreferenced image and the properties of that file – Ian Turton Jul 16 at 14:40
  • What happens if you go into the image properties - symbology- and set the color enhancement to no enhancement? – GBG Jul 16 at 15:03
  • 3
    Have you set the georeferencer to treat 0 values as No Data? It may be stripping black pixels out where it should not be – TeddyTedTed Jul 16 at 15:22
  • Try other resampling methods from the "Transformation settings" than Nearest neighbour that is the default. – user30184 Jul 16 at 22:55
  • Unfortunately, those suggestions did not produce a result. Can anyone do better in their own version of QGIS? – user115035 Jul 23 at 11:33

This is definitely a case of the georeferencer treating black pixels (value 0) as no data values, thus rendering them invisible.

When georeferencing, try having "Use 0 for transparency when needed" in the georeferencer Transformation settings dialog box unchecked.

Or, leave that checked, but then when your raster is loaded, go to the transparency properties for that raster and uncheck No data value. This will tell it to stop hiding black pixels (which it thinks are nodata values). You may need to do this by right clicking on the layer in the list and going to Properties > Styles rather than using the layer styling panel, if you use that at all; I find that the setting doesn't stick with the latter option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.