0

I have downloaded two Landsat 5 images because my study area is divided between the 2 tiles. I have created a composite of all the bands and then tried the mosaic tool in ArcMap but the result I have contains the black border that the raw images have and it is not correct. Is there a way how I could connect the 2 images in order to have only one image in the end to continue with my processing?

1

This 'black border' is probably 'background value' (normally RGB: 0,0,0). You can check the value of this 'black border' by using the Identify tool and clicking on it.

If I understood correctly, you need to remove or mask this background first before doing your mosaic layer by for example 'Mosaic to New Raster'.


  • One option, (if it is just about not seeing the background(: right-click on the composite layer and go to Layer properties/Symbology/RGB Composite and check: Display Backround Value as transparent.

  • Another option, (if you want to ignore this background pxels while processing and avoid processing errors of overlaping areas) is setting the target values as 'NoData'. You can easily achieve this by opening the ArcGIS Catalog as explained here. Right-click on your composite file (multiband raster) and go to General/ Raster Information. Edit the NoData Value and set it as desired (probably RGB: 0,0,0). An alternative method would be exporting to a new raster layer and setting the 'NoData' value to 0. From now on, ArcGIS tools should ignore this pixels.

  • I applied the ''Set null'' for each image separately but the output rasters are stretched and not appear as an RGB image anymore. Furthermore, the color ramp at one of the images is between the value 4 (low) and value 255 (high) and not 1 as the lowest value. – gispaew Jul 17 at 12:57
  • I edited the answer, maybe this does the trick. - What do you mean by: 'mosaic tool'? Was this 'Mosaic to New Raster'? Can you please be more precise? - Do you have overlapping areas between the two tiles, apart from the background value? How do you deal with these in your mosaic? – Ruben FV Jul 17 at 14:50
  • The area of my research contains a lake but on the upper part the lake is cut, therefore I have downloaded another image of the same time step. At the second image the lake is cut but at the lower part of the lake. Therefore, I have to connect the 2 downloaded images in order to fill the missing data of the lake. The lake is cut in both images because of the scene size, the lake is at the edge of each tile. Yes, I have tried the 'Mosaic to New Raster'. The mosaicking I did was wrong because I have not dealt with the background value before. – gispaew Jul 17 at 16:27
  • The trick with the ArcGIS Catalog did not worked for me because I was editing the NoData Value and set it to 0 for each band but it was somehow not working and not saving the change. I thought that the reason could cause that problem is the fact that the location of the 2 composites was inside a File Geodatabase. – gispaew Jul 17 at 16:43
  • 1
    The solution in my case: I exported the raster data and saved them in another location , outside the Geodatabase, while saving there is an option to set the '' NoData as '' for the output raster and I set it to 0. I was successful to remove the background values and afterwards having a Mosaic to a New Raster with the expected result. Thanks! – gispaew Jul 17 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.