1

I am new to QGIS and I realize this is probably a really silly question but I am at my wits end I've been trying to solve this for hours. I need to make a simple line layer to represent the sewer system through town but my "straight lines" will not stop curving out!

What can I do about this?

I think it has something to do with the "add circular string" tool I just can't seem to turn it off?

Photo shows a curved line, need this line to be straight/parallel to the lines beside it

1
1

As JGH correctly pointed out, the problem is the arrow style you're using.

Here's what a line looks like with the "simple line" style:

enter image description here

Here's what the same line looks like with the default "arrow" style:

enter image description here

The solution is to switch to a "simple line" style, OR if you want to keep using the arrow style, to un-check the box for "curved arrows."

enter image description here

Here's what the same line looks like with non-curved arrows:

enter image description here

1
  • That was it! Thank you all so much I can't believe I didn't think of that!! – jane Jul 18 '19 at 15:05
0

Try right-clicking on the top toolbar (toolbar panel?) and checking Shape Digitizing Toolbar.

You should be able to turn off Add Circular String that way.

To clarify: if you click Add Circular String, all new segments will curve from then on. You have to click on the Add Line Feature tool (that's what worked for me).

1
  • Please don’t clarify using comments on your own answer you can edit it. – PolyGeo Jul 18 '19 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.