0

I am trying to open a Jp2 file in QGIS 3.4.5 on a macOS 10.14.5 Mojave.

I am new to QGIS and have been looking through forums that discuss GRASS and GDAL but I don't understand the connection to QGIS.

DETAILS: - When I "drag and drop" I get the dreaded beachball and QGIS remains unresponsive. - The file is a statewide raster of magnetic data, roughly 120 MB. It also won't open in preview, with the following error "It may be damaged or use a file format that Preview doesn’t recognise". - The GDAL version is 2.4 which I downloaded and installed from www.kyngchaos.com.

Can you give me a simple explanation?

  • 2
    It should "just work"® for reading a JPEG2000. Please edit your question and specify what you tried and what happened, provide some details about the .jp2 if you can, and how you installed QGIS and what GDAL version QGIS was compiled & is running against (GDAL info is available in the QGIS Help -> About menu). – user2856 Jul 18 at 3:49
  • Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Your questions should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. Please check out our short tour for more about how the site works. Thanks. – PolyGeo Jul 18 at 3:51
  • 1
    I've added more detail. Not sure what you mean in regards to "how" I installed QGIS. I just downloaded and opened it. – sophie N Jul 18 at 4:12
  • If that .jp2 file is open data please share a link. – user30184 Jul 18 at 5:11
1

You say that when you try to open the file in the 'Preview' application on Mac OS X, it gives the error "It may be damaged or use a file format that Preview doesn’t recognise". Preview can open JP2 files, so that rules out the second part of that error and so the first part is probably the reason that Preview cannot open it. Ie, the file is damaged/corrupted.

To confirm if this is the case, try to open the file is some other application that can read JP2 files, such as Safari. If it won't open there, then it is definitely corrupted.

If the file is damaged/corrupted, then you most likely won't be able to open it in QGIS or any other application.

To be even more certain, you could try to download some other random JP2 file from somewhere else and make sure that it does open in Preview, Safari and QGIS.

  • Thanks, looks like that is the problem! Time to berate a government department :) – sophie N Jul 18 at 4:38
  • I guess it's possible that they could be producing a JP2 derivative that works for some software but not for others. – Son of a Beach Jul 18 at 4:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.