5

I need to export a GeoPackage file from QGIS 3.2 as CSV file. The GeoPackage contains two fields: UID as Integer and S_SCH as String (yes, it really is a string). It looks like:

UID S_SCH
654321 0920056
1256897 0920058

When I export this as CSV, QGIS adds thousand separators to the Integer field:

UID S_SCH
654.321,0920056
1.256.897,0920058

How can I prevent QGIS from doing this? I need it as plain Integer without any separators, just like in the original GeoPackage.

Note this is about exporting a CSV from QGIS, not about importing as all the questions I found so far. Exporting a .csvt won't help here as long as there are still separators in the integer field.

1
  • Could you try a more recent version of QGIS? I don't seem to have this issue on v3.8. – Joseph Jul 19 '19 at 10:08
5

I don't reproduce this behaviour with QGIS 3.4.8 ... Nevertheless the separator (in the .csv export) appear when the "show thousand separator" checkbox is checked in Options / General ...

1
  • For QGIS 3.2 see my own answer. However, for newer versions this is the correct answer. – MrXsquared Jul 21 '19 at 11:42
1

I can now confirm this is a QGIS 3.2 specific bug. This Problem does not exist in QGIS 2.18.15, 3.4.2 and 3.8.0.

The checkbox "Show thousands separator" in "Settings -> General" does not exist in QGIS 3.2. However, in newer versions unchecking it can solve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.