3

Basically I have a script that grabs data from a web service, parses it, stores it in an intermediary local fgdb, then appends that data to the feature class in the enterprise gdb.

The portion of the script that is taking forever is just this call inside of a function:

arcpy.Append_management(source_fc, target_fc, "NO_TEST")

From one featureclass in the fgdb to another, it is lightning quick

From the fgdb to the enterprise geodatabase, it takes 19 minutes. No matter the amount of rows. 10 rows, 100 rows, or 300 rows all take 19 minutes.

I tried the same exact data using arcpy and then using ArcMap. ArcPy took 19 minutes, ArcMap took 1 second. (For 138 records). These were tested on the same machine.

Any reason this would be doing this?

Edit: The 'target_fc' in this instance is not registered as versioned.

  • 1
    Have you tried searching GIS SE, this sort of question pops up quite regularly? Here is one possible reason. – Hornbydd Jul 20 at 0:34
  • Hi yes I did do some searching. The feature class is not registered as versioned, I should have noted that in the question. – user146474 Jul 22 at 17:01
  • If you try arcpy.copy or arcpy.FeatureClassToFeatureClass instead of append to an existing FC what is the performance like? I realize this might not be what you want but it might help narrow the problem down. Also what if you use a create cursor instead of append? Does this improve performance? – Dowlers Jul 26 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.