0

I have a very simple model built using Modelbuilder that takes a tab of an Excel spreadsheet and converts it using Make Table view. This works fine in ModelBuilder. I then export the model to Python to give the following code:

import arcpy
Combined_ = "D:\\EAD594\\EUforGIS.xls\\Combined$"
Combined_View = "Combined_View"
arcpy.MakeTableView_management(Combined_, Combined_View,...)

This gives the following error:

ExecuteError: Failed to execute. Parameters are not valid. ERROR 000732: Input Table: Dataset D:\EAD594\EUforGIS.xls\Combined$ does not exist or is not supported

Any ideas what could be causing this?

  • 1
    Excel and ArcGIS don't play together very well. I tried the code in the ArcCatalog Python window with the spreadsheet displayed and got the same error. I tried it in IDLE with the spreadsheet not open in any software and the code worked fine. You're most likely experiencing a lock issue. Close all software (Excel, ArcGIS, etc) which currently or previously had the spreadsheet open and try again. – Emil Brundage Jul 22 at 16:20
  • 1
    Adding to @EmilBrundage ' s comment, open windows task manager and kill all Excel Instances too. I find that sometimes Excel can start, but not open and sometimes locks can be held in memory. Especially if a script has failed. – Keagan Allan Jul 22 at 22:17
  • Thanks for the replies. I tried closing all software and also closing all Excel instances in task manager but still got the same problem - very strange. Let me know if you think of anything else! – user146578 Jul 23 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.