1

I am new to QGIS and want to learn some basic tools. However, after software installation I cannot execute any tool from the processing toolbox. All the tools is giving me the same error:

The following layers were not correctly generated. You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

The only tools which I could successfully perform so far are Contour tool and Clip raster by extent tool from Raster - Extraction tab.

Below is the example log for Line Smoothing tool:

Processing algorithm…
Algorithm 'Line smoothing' starting…
Input parameters:
{ 'ITERATIONS' : 10, 'LINES_IN' : 'D:/Tanaka/Ilandag_Contours.gpkg', 'LINES_OUT' : 'C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/efcdce475006430596a69e483d14fb24/LINES_OUT.shp', 'METHOD' : 2, 'PRESERVATION' : 10, 'SENSITIVITY' : 3, 'SIGMA' : 2 }

shapes_lines "Line Smoothing" -LINES_IN "C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/148495a26d744cb1957234b468b4f7c5/LINES_IN.shp" -METHOD 2 -SENSITIVITY 3 -ITERATIONS 10 -PRESERVATION 10.0 -SIGMA 2.0 -LINES_OUT "C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/efcdce475006430596a69e483d14fb24/LINES_OUT.shp"

C:\Users\Acer\Documents>set SAGA=D:/QGIS/apps\saga-ltr

C:\Users\Acer\Documents>set SAGA_MLB=D:/QGIS/apps\saga-ltr\modules

C:\Users\Acer\Documents>PATH=D:\QGIS\apps\qgis-ltr\bin;D:\QGIS\apps\grass\grass76\lib;D:\QGIS\apps\grass\grass76\bin;D:\QGIS\apps\Python37;D:\QGIS\apps\Python37\Scripts;D:\QGIS\apps\qt5\bin;D:\QGIS\apps\Python27\Scripts;D:\QGIS\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32\WBem;D:\QGIS\apps\Python37\lib\site-packages\pywin32_system32;D:\QGIS\apps\Python37\lib\site-packages\numpy\.libs;;D:/QGIS/apps\saga-ltr;D:/QGIS/apps\saga-ltr\modules

C:\Users\Acer\Documents>call saga_cmd shapes_lines "Line Smoothing" -LINES_IN "C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/148495a26d744cb1957234b468b4f7c5/LINES_IN.shp" -METHOD 2 -SENSITIVITY 3 -ITERATIONS 10 -PRESERVATION 10.0 -SIGMA 2.0 -LINES_OUT "C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/efcdce475006430596a69e483d14fb24/LINES_OUT.shp"
____________________________

##### ## ##### ##
### ### ## ###
### # ## ## #### # ##
### ##### ## # #####
##### # ## ##### # ##
____________________________

SAGA Version: 2.3.2 (32 bit)

____________________________
library path: D:\QGIS\apps\saga-ltr\modules\
library name: shapes_lines
library : Lines
tool : Line Smoothing
author : V. Wichmann, J. Engels (c) 2014
processors : 2 [2]
____________________________

Load shapes: C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/148495a26d744cb1957234b468b4f7c5/LINES_IN.shp...


Parameters

Lines: LINES_IN
Smoothed Lines: Smoothed Lines
Method: Gaussian Filtering
Sigma: 2.000000

Length of the Gaussian window: 15

Error: executing tool [Line Smoothing]

C:\Users\Acer\Documents>exit
Execution completed in 15.05 seconds
Results:
{'LINES_OUT': 'C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/efcdce475006430596a69e483d14fb24/LINES_OUT.shp'}

Loading resulting layers
The following layers were not correctly generated.<ul><li>C:/Users/Acer/AppData/Local/Temp/processing_9da93462bf9f4ec8af00f5e24a02cd1e/efcdce475006430596a69e483d14fb24/LINES_OUT.shp</li></ul>You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

I am using QGIS version 3.4.10-Madeira long term release. Looking forward for your help!

closed as unclear what you're asking by ahmadhanb, Kadir Şahbaz, Fran Raga, whyzar, xunilk Aug 1 at 18:14

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Really any? Try some from non-SAGA trees please, do those also not work? – bugmenot123 Jul 26 at 8:24
  • Also try seeing if they work when you save to a non-temporary work space. – AWGIS Jul 26 at 15:04
  • The same problem for the GRASS split tool: The following layers were not correctly generated.<ul><li>D:/Tanaka/Split.gpkg</li></ul>You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm. – Ruslan Jul 26 at 21:11
  • However, could execute GDAL Aspect tool. It seems like I could perform the tools dealing with vector data. Really don't understanda what can be the problem.. – Ruslan Jul 26 at 21:18