1

I am using ArcMap 10.3.1 and trying to make a connection with federated ArcGIS Server 10.6.1.

I am Getting this error message:

We were unable to connect to: http://arcgisserver:6443/arcgis. Error : Bad syntax in request. (status code 400)

enter image description here

What could the problem be?

  • Welcome to GIS SE! As a new user be sure to take the Tour. For questions that involve error messages we ask that you show us them in full using text rather than a picture so that they can be searched and also read easily on all devices. There is an edit button beneath your question which will enable you to do that and a " " button that enables you to format any highlighted text nicely. – PolyGeo Jul 30 at 9:23
  • 1
    Given that you are trying to connect three major releases into the future, you should start by reviewing the compatibility documentation, to see if this is possible. – Vince Jul 30 at 9:25
  • 1
    according to the official documentation of esri, it is possible to connect to arcgis server 10.6.1 with a previous version of arcgis desktop – med youssef akesbi Jul 30 at 9:39
2

From the ArcGIS manual About Connecting to ArcGIS Server in ArcGIS for Desktop:

Specifying the server URL Specifying the server URL When you connect, you'll be asked to type the URL to your ArcGIS Server site. For user connections, you'll often include the name of the ArcGIS Web Adaptor in your URL. This will look like http://webadaptorhost.domain.com/webadaptorname/services.

For publisher and administrative connections, access through the web adaptor is blocked by most organizations. Instead, you need to use the administrative URL of the server, which takes the format http://gisserver.domain.com:6080/arcgis.

Some sites may require an HTTPS connection through port 6443. Check with your server administrator if you are unsure of the appropriate URL to use.

If you receive an error when connecting, one of more of the following may be the cause:

  • You typed an incorrect name or password.
  • You did not use your server’s expected protocol of HTTP or HTTPS.
  • You did not include the fully qualified domain name of the server (which is required in scenarios where the server is federated with Portal for ArcGIS).

It is worth also to read the Compatibility of ArcGIS for server with earlier versions

Can I view and use my 10.6.1 services within an earlier version of ArcGIS Desktop?

You can add 10.6.1 services to earlier versions of ArcGIS Desktop and use them in the same way that you used them in the past, including as a layer in ArcMap. However, if your ArcGIS Server10.6.1 site is federated with Portal for ArcGIS and the portal is configured with Security Assertion Markup Language (SAML), you must at least use ArcGIS Desktop 10.3.

If your 10.6.1 ArcGIS Server site is federated with Portal for ArcGIS and you are connecting from a pre-10.2 version of ArcGIS Desktop, you must access your services through ArcMap using Add Data > Add Data from Portal for ArcGIS. You cannot connect to the server by clicking Add ArcGIS Server.

  • i am using 10.3.1 version of ArcGIS Desktop, the article talks about a version < 12.1 – med youssef akesbi Jul 30 at 10:55
  • Every ArcGIS for Desktop in earlier versions can connect to the 10.6.1 ArcGIS Server if they are not configured by Portal for ArcGIS. – sk1me Jul 30 at 11:11
0

Can the problem be that you are using http to access a port that requires https?

https://enterprise.arcgis.com/en/server/latest/install/windows/ports-used-by-arcgis-server.htm

Normally it should default to 6443 when you use https. Do you get the same error if you try https://arcgisserver/arcgis?

0

Your connection string starts with HTTP, but port 6443 works just for HTTPS. For HTTP use port 6080.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.