1

I am wanting to represent polygons as dashed lines without filling the interior of the polygon. But there is the common edge between polygons, and so the visual effect of the lines vary. Depending on the zoom level (scale) there are places that appear as dashed lines, in other places that appear as continuous lines. How could I eliminate these visual effects in QGIS 3.4.10?

Figure 01

enter image description here

Figure 02

enter image description here

I tried the solutions for this question: How to remove line segments from a polygon for borders on a map in QGIS?

  • I tried the geometry generator option and also tried to create a virtual layer with the st_boundary option, but in both cases double lines are generated in the contacts of the polygons. I didn't find any command that generates an SQL without duplicate lines in the contacts.
  • I also tried using the "force right hand-rule orientation" option but I saw no result.
5
  • 1
    I've seen these solutions, but solution 1 will be the last option, I will only use it if I can't find another one. I tested solution 2 but as it is only 1 polygon feature, there was no practical effect as shown in the example. Solution 3 does not work because I have other layers.
    – Denilson
    Jul 30 '19 at 19:49
  • I tried with the geometry generator option and also tried to create a virtual layer with the st_boundary option, but in both cases double lines are generated in the contacts of the polygons. I didn't find any command that generates an SQL without duplicate lines in the contacts. I also tried using the "force right hand-rule orientation" option but I saw no result.
    – Denilson
    Jul 30 '19 at 19:50
  • I'm confused. What do you mean it's only one polygon feature? In your screenshots I see multiple polygons. Do you mean that they're all parts of a single multipart feature? The second method (add a second symbol layer) should work even with a multipart polygon.
    – csk
    Jul 30 '19 at 21:38
  • it's just a counties feature, but in this feature we have dozens of polygons. I performed tests with the second method, but it didn't solve the problem.
    – Denilson
    Jul 31 '19 at 11:17
  • I can't reproduce a situation where that method doesn't work. Can you update your question with some screenshots and an explanation of exactly what steps you took to try to implement it?
    – csk
    Jul 31 '19 at 17:42

Browse other questions tagged or ask your own question.