1

I'm having trouble getting GeoServer to create audit logs outside its own directory. I'd prefer (possibly need) to do it this way as I'm getting a script to read them via FTP, which can't read from the GeoServer directory

If I set the monitor.properties to be inside the GeoServer directory, it all works happily

[root@maps geoserver]# ls -l /var/lib/tomcat/geoserver/webapps/geoserver/
total 56
drwxr-xr-x  2 tomcat tomcat 36864 Aug  5 10:45 logs

If I try and set it elsewhere, it doesn't want to work. I've tried changing the owner and even directory permissions to 777, but still nothing appears here. Oddly enough nothing appears in the normal GeoServer logs about this either, with development logging enabled.

[root@maps geoserver]# ls -l /home/shape_uploads/
total 8
drwxrwxrwx 2 tomcat        tomcat        4096 Aug  5 08:26 geoserver_logs

Here's my monitor.properties file:

# the storage mode, one of: memory, hibernate
# Note: hibernate mode requires the hibernate extension
storage=memory

audit.enabled=true
audit.path=/home/shape_uploads/geoserver_logs
#audit.path=/var/lib/tomcat/geoserver/webapps/geoserver/logs
audit.roll_limit=100

# the monitor mode, one of: live, history
mode=history

# synchronization mode, one of: sync, async, async_update
#
# WARNING: this is an advanced configuration option. You probably do not want
# to change this unless instructed to by a developer
sync=async

# The maximum allowable length for a request body (in bytes).  Longer bodies will be trimmed to
# this length.
maxBodySize=1024

# Disable logging of bodies entirely
# maxBodySize=0

# Allow unlimited body lengths.  This could take up a lot of space quite rapidly.
# maxBodySize=-1

# If you increase or unbound the maximum body length, you must also change the hibernate mappings
# file.


# The CRS to log bounding boxes in
bboxLogCrs=EPSG:3857

# Bounding Box Log Level: controls when to record bounding boxes.
# 'none': Don't record bounding boxes
# 'no_wfs': Record bounding boxes for WMS and WCS requests, but not WFS.  This is the default
# 'full': Record a bounding box for all requests for which one can be produced.  WFS is not amenable
#         to being logged this way so the boxes produced will be approximate at best.
bboxLogLevel=full

Am I doing something obviously wrong, or is it not possible?

We're running on CentOS with tomcat if that makes any difference

  • You're right. I moved it to the /var/log/tomcat directory and it's writing them there all happily. Thanks for the tip! – Alistair R Aug 6 at 7:09
  • Please write that as an answer. – user30184 Aug 6 at 9:26
1

/home/ could be the source of the issue.

If geoserver runs as a service, it may not (shouldn't?) have a home directory. Also the user running the service would have to be the same as the user specified in the ftp connection, which is not a standard setup.

Use a shared folder on another directory than /home/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.